

<!DOCTYPE html>
<html>
<head>
	<!-- AID: 12654 - 2020-05-15 - 100  -->

	<!-- set the encoding of your site -->
	<meta charset="utf-8">
	<!-- set the viewport width and initial-scale on mobile devices -->
	<meta name="viewport" content="width=device-width, initial-scale=1.0">
	<meta http-equiv="X-UA-Compatible" content="IE=Edge" />

	<title> Mouseplanet - My Disney Top 5 - Places in Walt Disney World I'd Like To Be Right Now by Chris Barry </title>

	<!-- include the site stylesheet -->
	<link media="all" rel="stylesheet" href="/css/fancybox.css" />
	<link media="all" rel="stylesheet" href="/css/all.css">

	<meta name="twitter:card" content="summary" />
	<meta name="twitter:site" content="@MousePlanet" />
	<meta name="twitter:title" content="My Disney Top 5 - Places in Walt Disney World I'd Like To Be Right Now" />
	<meta name="twitter:description" content="Chris looks at his favorite places to be throughout the Walt Disney World Resort." />
	<meta name="twitter:image:src" content="https://www.mouseplanet.info/gallery/d/259734-2/ASD-12182016+-+15.jpg" />
	<meta property="og:url"                content="https://www.mouseplanet.com/12654/My_Disney_Top_5__Places_in_Walt_Disney_World_Id_Like_To_Be_Right_Now" />
	<meta property="og:type"               content="article" />
	<meta property="og:title"              content="My Disney Top 5 - Places in Walt Disney World I'd Like To Be Right Now" />
	<meta property="og:description"        content="Chris looks at his favorite places to be throughout the Walt Disney World Resort." />
	<meta property="og:image"              content="https://www.mouseplanet.info/gallery/d/259734-2/ASD-12182016+-+15.jpg" />
	
	<link rel="image_src" href="https://www.mouseplanet.info/gallery/d/259734-2/ASD-12182016+-+15.jpg" / >	
	<link rel="alternate" type="application/rss+xml" title="RSS" href="/rss/articles_feed.xml" />

	
<script type="text/javascript">
String.prototype.trim = function() {
  return this.replace ( /^\s+|\s+$/g, "" );
};
</script>



<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-97843-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-97843-1');
</script>



<!-- Start Google Adsense Mobile Vignettes -->
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-8218384467922636",
    enable_page_level_ads: true
  });
</script>
<!-- End Google Adsense Mobile Vignettes -->



<!-- QST ADS
<script type="text/javascript">
(function() {var s=document.createElement('script'); s.type='text/javascript'; s.async=true; s.src='//qualitysocialtargeting.liqwid.net/?key=D85D-A6F1-B041-B88A';var x=document.getElementsByTagName('script')[0];x.parentNode.insertBefore(s,x);})();
</script>
END OF QST ADS -->

		
	<!-- Start Google DFP -->
	<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
	<script>
	  var googletag = googletag || {};
	  googletag.cmd = googletag.cmd || [];
	</script>
		
	<script type='text/javascript'>
		googletag.cmd.push(function() {
			
		var mapping = googletag.sizeMapping().
			addSize([980, 0], [728, 90]).addSize([640, 0], [300, 250]).build();
		var mapping1 = googletag.sizeMapping().
			addSize([980, 0], [728, 90]).addSize([640, 0], [300, 250]).build();
		var mapping2 = googletag.sizeMapping().
			addSize([980, 0], [728, 90]).addSize([640, 0], [300, 250]).build();
		var mapping3 = googletag.sizeMapping().
			addSize([980, 0], [728, 90]).addSize([640, 0], [300, 250]).build();
		var mapping4 = googletag.sizeMapping().
			addSize([980, 0], [728, 90]).addSize([640, 0], [300, 250]).build();
		var mapping5 = googletag.sizeMapping().
			addSize([980, 0], [728, 90]).addSize([640, 0], [300, 250]).build();
		var mapping6 = googletag.sizeMapping().
			addSize([980, 0], [728, 90]).addSize([640, 0], [300, 250]).build();
		var mapping7 = googletag.sizeMapping().
			addSize([980, 0], [728, 90]).addSize([640, 0], [300, 250]).build();
		var mapping8 = googletag.sizeMapping().
			addSize([980, 0], [728, 90]).addSize([640, 0], [300, 250]).build();
		var mapping9 = googletag.sizeMapping().
			addSize([980, 0], [728, 90]).addSize([640, 0], [300, 250]).build();
		var mapping10 = googletag.sizeMapping().
			addSize([980, 0], [728, 90]).addSize([640, 0], [300, 250]).build();
		var mapping11 = googletag.sizeMapping().
			addSize([980, 0], [728, 90]).addSize([640, 0], [300, 250]).build();
		var mapping12 = googletag.sizeMapping().
			addSize([980, 0], [728, 90]).addSize([640, 0], [300, 250]).build();
		var mapping13 = googletag.sizeMapping().
			addSize([980, 0], [728, 90]).addSize([640, 0], [300, 250]).build();
		
			    googletag.defineSlot('/1046630/tag_WDW_lb', [[300, 250], [728, 90]], 'div-gpt-ad-1440716678880-46').defineSizeMapping(mapping13).addService(googletag.pubads());	    googletag.defineSlot('/1046630/tag_WDW_cube', [[300, 600], [300, 250]], 'div-gpt-ad-1440716678880-45').addService(googletag.pubads());			
		googletag.defineSlot('/1046630/ros_footer', [728, 90], 'div-gpt-ad-1324422172992-25').addService(googletag.pubads());
	    googletag.pubads().enableSingleRequest();
	    googletag.enableServices();
	    googletag.pubads().collapseEmptyDivs();
	
		});
		</script>
		<!-- End Google DFP -->			
		

	<script type="text/javascript">
		$(document).ready(function() {
			var photoList = $('.phototour img');
			if (photoList.length) {
				$('meta[name="twitter:image:src"]').attr('content', photoList[0].src);
			}
		});
	</script>

</head>
<body>
	<!-- main container of all the page elements -->
	<div id="wrapper">
		

<div class="top-bar">
			<div class="top-holder">
				<ul class="social-networks">
					<li><span class="text-follow">Follow us on</span></li>
					<li><a class="facebook" href="https://www.facebook.com/mouseplanet" target="_blank">Facebook</a></li>
					<li><a class="twitter" href="https://twitter.com/MousePlanet" target="_blank">Twitter</a></li>
					<li><a class="youtube" href="https://www.youtube.com/user/MousePlanetVideo" target="_blank">Youtube</a></li>
					<li><a class="instagram" href="https://instagram.com/mouseplanet/">Instagram</a></li>
				</ul>
			</div>
		</div>
		<!-- header of the page -->
		<header id="header">
			<div class="holder">
				<!-- logo of the page -->
				<div class="logo">
					<a href="/"><img src="/mplogo.gif" alt="MousePlanet"></a>
				</div>
				<!-- main navigation of the page -->
				<nav id="nav">
					<!-- <div class="open-close"> -->
					<a href="#" class="nav-opener"><span></span></a>
					<div class="drop">
						<!-- search-form of the page -->
						<form action="/search.php" class="search-form" method="post">
							<fieldset>
								<div class="row">
									<input type="search" id="t" name="t" placeholder="Search">
									<input type="submit">
								</div>
							</fieldset>
						</form>
						<ul>
							<li>
								<a href="/articles.php">Articles</a>
							</li>
							<li><a href="/guide/1/Disneyland-Resort">Disneyland Guide</a>
								<ul class="dropmenu">
									<li><a href="/guide/1/Disneyland-Resort">Quick Facts</a></li>
									<li><a href="/tag/2/Disneyland_Resort_Update/">Resort Updates</a></li>
									<li><a href="/guide/448/Disneyland-Resort/Disneyland-Park">Disneyland</a></li>
									<li><a href="/guide/274/Disneyland-Resort/Disney-California-Adventure">Disney California Adventure</a></li>
									<li><a href="/guide/464/Disneyland-Resort/Downtown-Disney">Downtown Disney</a></li>
									<li><a href="http://mousepad.mouseplanet.com/forumdisplay.php?53-Trip-Reports-from-California">Trip Reports</a></li>
								</ul>
							</li>
							<li><a href="/guide/2/Walt-Disney-World">Walt Disney World Guide</a>
								<ul class="dropmenu">
									<li><a href="/guide/2/Walt-Disney-World">Quick Facts</a></li>
									<li><a href="/tag/101/Walt_Disney_World_Resort_Update/">Resort Updates</a></li>
									<li><a href="/guide/550/Walt-Disney-World/Magic-Kingdom">Magic Kingdom</a></li>
									<li><a href="/guide/303/Walt-Disney-World/Epcot">Epcot</a></li>
									<li><a href="/guide/436/Walt-Disney-World/Disneys-Hollywood-Studios">Disney's Hollywood Studios</a></li>
									<li><a href="/guide/15/Walt-Disney-World/Disneys-Animal-Kingdom">Disney's Animal Kingdom</a></li>
									<li><a href="/guide/395/Walt-Disney-World/Downtown-Disney">Downtown Disney / Disney Springs</a></li>
									<li><a href="http://mousepad.mouseplanet.com/forumdisplay.php?54-Trip-Reports-from-Floridaa">Trip Reports</a></li>
								</ul>
							</li>
							<li><a href="http://mousepad.mouseplanet.com">Forum</a></li>
						</ul>
					</div>
					<!-- </div> -->
				</nav>
			</div>
		</header>		<!-- contain main informative part of the site -->
		<main id="main" role="main">
			<div class="holder padding">
				<div class="ad-holder">
					<!-- /1046630/tag_WDW_lb -->
<div id='div-gpt-ad-1440716678880-46'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1440716678880-46'); });
</script>
</div>				</div>

				<div class="heading">
										<h1>My Disney Top 5 - Places in Walt Disney World I'd Like To Be Right Now</h1>
					
											by <a href="/author/44/Chris_Barry/" class="name">Chris Barry</a>, contributing writer						<a href="/contact/w/44/Chris-Barry" title='Send Chris Barry an email'><img src="/images/mail.png" height="20"></a>
										<time datetime="2020-05-15">May 15, 2020</time>
				</div>

				<div class="content-holder">
					<div class="ad-block">
						<h6>Advertisement</h6>
						<div class="ad-holder">
							<!-- /1046630/tag_WDW_cube -->
<div id='div-gpt-ad-1440716678880-45'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1440716678880-45'); });
</script>
</div>						</div>
					</div>
					<div class="text-holder">
						<p>Welcome back to another Disney Top 5. As always, I hope everyone out there is doing well. Time passes on. It's hard to believe this has all been going on for just about 2 months already. Think about that. 2 months. The same amount of time as an entire summer vacation. Once again, I can't complain. I'm grateful that everyone in my family is doing just fine. I do have some friends and relatives that were sick and, thankfully, they are all on the mend. My wife is running her business. I'm doing my best trying to teach my students from home. Everyone, including the dog, needs a haircut. But, all things considered, we're all OK.</p>

<p>I'm going to state for the record that I love my house. We've been here for almost 22 years now. It's old, which means it has charm, which also means some of the floors and walls are crooked and some of the windows don't close exactly right. But I love it. It's ours. It's been a labor of love since day one, but it's where we we raised the kids and grew into our marriage and therefore, it's eternal. That said let's remember that I work and live in the same town, a town that's a little off the beaten path to begin with. The point is, even pre-pandemic, I didn't leave town all that much. Now, of course, I know every nook and cranny of this house, yard, garage and driveway even more intimately than I could have ever thought. The prospect of going somewhere different - anywhere really - has been growing on me for the past two months now.</p>

<p>Mentally, I'm traveling to lots of places. I haven't seen my daughter in months and I'd love to be walking around Boston with her right now stopping into that awesome bakery with the killer scones. It actually snowed here the other day - in May mind you - and I immediately thought about Vermont and ducking into my favorite tree skiing trail with all three of my kids in tow. What I wouldn't give to be sitting on that awesome beach in Turks and Caicos with my wife watching the sunset or walking on the beach in Cape Cod like we all did last summer. But this is a Disney website, and I write about Disney don't I? So, you can imagine, I've got a whole list of places in Walt Disney World that I've been mentally traveling to for the past few months as well. Where would I love to be right now? Lots of places. Where would I want to be right now if I were at Disney? Let's find out with my Top 5 places in Walt Disney World I'd like to be right now.</p>

<h3>5 - Flame Tree Barbecue Seating Areas - Animal Kingdom</h3>

<p>I'd be hard pressed to find a place in all of Walt Disney World that I like more to sit, relax and have some good food in the outdoors. Flame tree Barbecue is located on Discovery Island close to the Dinoland entrance. At first, it may not seem like much more than another Disney counter service spot. The building itself is kind of cool and the food is quite good, but it's the seating areas that make this place such a find. Much like many places in Walt Disney World, you have to dig a little deeper and explore just a little bit more to find the real treasures. Seating for Flame Tree is set back in the lush gardens typical of Animal Kingdom.</p>

<p><p class="phototour"><a title="The upper level outdoor seating for Flametree Barbecue at Animal Kingdom. Photo by Alan Dalinka." rel="lightbox" href="https://www.mouseplanet.info/gallery/d/258646-1/ASD-12042016ak+-+4.jpg"><img width="400" height="300" border="0" alt="" src="https://www.mouseplanet.info/gallery/d/258650-2/ASD-12042016ak+-+4.jpg"></a><br>The upper level outdoor seating for Flametree Barbecue at Animal Kingdom. Photo by Alan Dalinka.</p></p>

<p>Walk behind the building with your food and you'll find dining pavilions scattered along the waterfront with views of Everest off in the distance. But my favorite spots have to be the tables nestled alongside the reflecting pool in the center. It's shady. It's tropical. It's spread out so you're not on top of one another. It's a whole world away from the busy theme park and crowded walkways located just a few yards away. Tomorrow during my usual lunch in the kitchen with my newspaper, I'd like to snap my fingers and be eating the pulled pork or the smoked chicken salad with a cold Safari Amber right next to the reflecting pools at Flame Tree Barbecue.</p>

<h3>4 - Bay Lake/Seven Seas Lagoon</h3>

<p>That may seem a little broad to some of you as I am talking about two distinctly different bodies of water, the manmade lagoon in front of the Magic Kingdom and the adjacent natural lake with The Wilderness Lodge, Contemporary Resort and Fort Wilderness lining its shores. To me, it's all part of one experience though. One of the joys of staying at one of the Magic Kingdom resorts is being just a boat ride away from the kingdom itself. Some of my most tranquil and most favorite moments at Disney have been either on the boat ride over to the Magic Kingdom or at night, on a boat ride back to our resort.</p>

<p><p class="phototour"><a title="Get me out on the Seven Seas Lagoon or Bay Lake in one of these Disney launches and I'm a very happy man. Photo by Donald Fink." rel="lightbox" href="https://www.mouseplanet.info/gallery/d/273211-2/17-Water+Transportation.jpg"><img width="400" height="300" border="0" alt="" src="https://www.mouseplanet.info/gallery/d/273215-2/17-Water+Transportation.jpg"></a><br>Get me out on the Seven Seas Lagoon or Bay Lake in one of these Disney launches and I'm a very happy man. Photo by Donald Fink.</p></p>

<p>I'm most fond of the older looking launch boats. They're classic and make the ride that much more special. I like to write late at night, so it's about midnight as I'm writing this. I'd love to be on one of the launch boats right now after a perfect night at the Magic Kingdom. Everyone's tired. The moon is out and reflecting on the water and we're headed slowly back across the water to our room at The Polynesian without a care in the world. That sounds pretty good right about now doesn't it?</p>

<h3>3 - Rivers of America Waterfront</h3>

<p>This has always been one of my favorite places in the Magic Kingdom and probably one of my favorite spots on Disney property. If we're ever headed towards either Big Thunder Mountain or Splash Mountain from Liberty Square, or vide-versa, I just about always will head towards the Rivers of America and walk along the waterfront walkway instead of the main drag. It probably doesn't shave off any time. As a matter of fact, it's probably longer. But, you know that whole "road less traveled" thing? Robert Frost was right. It pays off every single time.</p>

<p><p class="phototour"><a title="It's hard to beat a walk along the Rivers of America. Photo by Alan S. Dalinka." rel="lightbox" href="https://www.mouseplanet.info/gallery/d/260627-1/ASD2017-0105+-+3.jpg"><img width="400" height="300" border="0" alt="" src="https://www.mouseplanet.info/gallery/d/260631-2/ASD2017-0105+-+3.jpg"></a><br>It's hard to beat a walk along the Rivers of America. Photo by Alan S. Dalinka.</p></p>

<p>I'm always amazed at just how few people are actually walking along this beautiful boardwalk. We've literally been alone on it while the main path was packed. You get a wonderful view of Tom Sawyer Island and Big thunder off in the distance. if you're lucky, the riverboat might come chugging by. There are waterfalls and streams leading into the river, and on the way back, you can get a beautiful view of Cinderella Castle towering over the buildings of Liberty Square. We've been going on walks just about every day around our neighborhood over the last two months and that's been great family time. But just once it'd be nice to swap my neighbor's lawns for the Rivers of America for one of our daily strolls. I wouldn't even have to have a FastPass to Big Thunder to make it worth it.</p>

<h3>2 - World Showcase Lagoon - After Illuminations</h3>

<p>OK. I'm slightly dating myself. I realize Illuminations is gone. I was there for the last ever show this past fall, so I know it's gone. However, over the many years and many trips to Walt Disney World, one thing has remained a constant with me. Sticking around in World Showcase after the fireworks extravaganza is consistently one of the most magical times of my whole vacation. I realize that's a powerful statement but it's definitely true. I make this a rule of thumb in all four parks, but especially in Epcot and I'm always amazed at the mass exodus that occurs once the nighttime shows come to a close. Why rush out? Just to get to a crowded bus, monorail, parking lot tram or traffic line? I guess most guests just aren't aware that the parks typically stay open for an hour after the official posted closing time. The cast doesn't chase you out right away. We've stayed in our favorite Illuminations spot, which is Germany, for a good 30-40 minutes watching the crowd disappear. Then we can slowly meander though a virtually empty World Showcase. We take photos. We stop in each country and look out across the lagoon.</p>

<p><p class="phototour"><a title="My boys and I in the Italy pavilion just after the final Illuminations this past September. It's hard to tell but we were pretty much alone. Photo by Chris Barry." rel="lightbox" href="https://www.mouseplanet.info/gallery/d/334647-1/IMG_0084.jpg"><img width="400" height="300" border="0" alt="" src="https://www.mouseplanet.info/gallery/d/334651-2/IMG_0084.jpg"></a><br>My boys and I in the Italy pavilion just after the final Illuminations this past September. It's hard to tell but we were pretty much alone. Photo by Chris Barry.</p></p>

<p>As corny as it sounds, it's simply a magical time to be there. You spend all day in the crowds and then for a brief amount of time, you can have it all to yourself. Right now, I'd love to be in the Italy pavilion close to closing time, hanging out down by the lagoon, taking pictures and talking with the family as we quietly make our way back to our room at The Yacht Club.</p>

<h3>1 - Our Balcony at The Yacht Club</h3>

<p>We spent many years at Caribbean Beach and Port Orleans, both Riverside and French Quarter before we got a great deal and splurged on a room at The Yacht Club. With one or two exceptions, we've never gone back. Once you go Deluxe, it's hard to go back. I know it costs more, and it's a stretch for us at times. But there are a dozen good reasons to splurge if you can. One of the best reasons to upgrade to a Deluxe hotel at Walt Disney World is the addition of a private balcony in your room, especially our all time favorite resort, Disney's Yacht Club.</p>

<p><p class="phototour"><a title="Many years ago on one of our many Yacht Club balconies. Photo by Samantha Barry." rel="lightbox" href="https://www.mouseplanet.info/gallery/d/334653-1/Yacht+Club+Balcony.jpg"><img width="400" height="300" border="0" alt="" src="https://www.mouseplanet.info/gallery/d/334657-2/Yacht+Club+Balcony.jpg"></a><br>Many years ago on one of our many Yacht Club balconies. Photo by Samantha Barry.</p></p>

<p>We start every Disney day out on the balcony watching the resort wake up and come to life. My wife goes on her morning run down to the Studios and back. She stops at the BoardWalk Bakery, brings us up some fruit and muffins and we start planning our adventures. Once the day is done we open some wine and head right back out to the balcony. The kids are usually down in the quiet pool and the adults can power down, reminisce about previous trips, recap the day and look ahead towards doing it all over again tomorrow. If we're lucky, we're traveling with our best Disney traveling friends, and they come over as well. Despite the exhausting day, we spend a few hours out there each night talking, laughing and relaxing. Once again, much like staying behind in Epcot, I'm always surprised by how few people are out on their balconies in the resort. Despite the Orlando swelter, we're usually just fine out there. The mornings are cool. The nighttime is quiet. For me, it's the best place to be at Walt Disney World because I'm either about to start another awesome day, or I've just finished one, so, really, no matter when I'm sitting out there, I'm happy and at peace.</p>

<p>As usual, these lists are hard to narrow down. I could have easily put "hanging on the beach at the Polynesian watching the fireworks across the lagoon," or "sitting in a rocking chair on Tom Sawyer Island watching the trains of Big Thunder go whizzing by," or a few dozen others. But these are the ones that I've been thinking about the most right now, as I'm home, unsure of when I'll be back again. When our good friend Paula was at our house and it got late, she would always say, "I wish I could just blink myself home like Jeannie." (That's an I Dream of Jeannie reference out there for you young people!) Well these are the places at Walt Disney World where I'd really like to be able to "Jeannie blink" to if I could right now. Like I said, I'm doing fine. We're all healthy here. We're very fortunate. But that doesn't mean I can't wish I was somewhere else, even just for a moment does it?</p>

<p>That's all for this time. As always, I'd like to hear what you have to say. Click on the link below, let me hear your thoughts about where you'd "Jeannie blink" yourself too and I'll see you next time with another Disney Top 5.</p>

<p>Before I go, I'd like to remind you all to tune in to our weekly MousePlanet Live stream. Join MousePlanet contributors and special guests each week for some socially distant chat. "Fun At Home" runs each Wednesday night, typically @ 8:30 p.m.. EDT/5:30 p.m.. PDT.</p>
<p>&nbsp</p>
					<p>
						<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
						<ins class="adsbygoogle"
						     style="display:block"
						     data-ad-format="autorelaxed"
						     data-ad-client="ca-pub-8218384467922636"
						     data-ad-slot="7483507399"></ins>
						<script>
						     (adsbygoogle = window.adsbygoogle || []).push({});
						</script>

					</p>

					</div>
				<div class="social-block">
					<div class="info-share">
						<h4>Share this article</h4>
							<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-514bcc3157fb0a34" async="async"></script>
							<div class="addthis_sharing_toolbox"></div>
					</div>
					<div class="info-tag">
						<h4>Tags</h4>
						<ul class="list-tags">
							<li><a href="/tag/100/Walt_Disney_World_Resort/">Walt Disney World Resort</a></li><li><a href="/tag/1231/Flame_Tree_Barbecue/">Flame Tree Barbecue</a></li><li><a href="/tag/1103/Rivers_Of_America/">Rivers Of America</a></li><li><a href="/tag/1057/World_Showcase/">World Showcase</a></li><li><a href="/tag/1269/Yacht_Club/">Yacht Club</a></li>						</ul>
					</div>
				</div>

				<article class="article-info">
					<h4>Similar Articles</h4>
					<ul class="list-articles">

							<li>	<a href="/12648/Things_We_Miss_About_Walt_Disney_World_Part_1" class="img-holder">	<img src=" https://www.mouseplanet.info/gallery/d/334378-2/101-Fireworks+at+the+Magic+Kingdom.jpg" alt="Things We Miss About Walt Disney World, Part 1" width="261" height="193"></a>	<a href="/12648/Things_We_Miss_About_Walt_Disney_World_Part_1" class="title">Things We Miss About Walt Disney World, Part 1</a>	<br /><span class="author">by <a href="/12648/Things_We_Miss_About_Walt_Disney_World_Part_1" class="name">Donald and Bonnie Fink</a> <time datetime="2020-05-15">May 15, 2020</time></span>  </li><li>	<a href="/12622/The_2020_Epcot_International_Flower_and_Garden_Festival_A_Photo_Tour" class="img-holder">	<img src=" https://www.mouseplanet.info/gallery/d/333612-2/101-Flower+and+Garden+Festival.jpg" alt="The 2020 Epcot International Flower and Garden Festival: A Photo Tour" width="261" height="193"></a>	<a href="/12622/The_2020_Epcot_International_Flower_and_Garden_Festival_A_Photo_Tour" class="title">The 2020 Epcot International Flower and Garden Festival: A Photo Tour</a>	<br /><span class="author">by <a href="/12622/The_2020_Epcot_International_Flower_and_Garden_Festival_A_Photo_Tour" class="name">Donald and Bonnie Fink</a> <time datetime="2020-04-09">April 9, 2020</time></span>  </li><li>	<a href="/12596/Disneys_Caribbean_Beach_Resort_A_Photo_Tour" class="img-holder">	<img src=" https://www.mouseplanet.info/gallery/d/332671-2/101-Caribbean+Beach+Resort.jpg" alt="Disney's Caribbean Beach Resort: A Photo Tour" width="261" height="193"></a>	<a href="/12596/Disneys_Caribbean_Beach_Resort_A_Photo_Tour" class="title">Disney's Caribbean Beach Resort: A Photo Tour</a>	<br /><span class="author">by <a href="/12596/Disneys_Caribbean_Beach_Resort_A_Photo_Tour" class="name">Donald and Bonnie Fink</a> <time datetime="2020-03-12">March 12, 2020</time></span>  </li>


					</ul>					
				</article>
			</div>

			<div class="comment-block">
				<div class="holder">
					<h2>Comments</h2>
					<ol class="list-comments">

						<li><strong class="comment-info"><a href="https://mousepad.mouseplanet.com/showthread.php?t=297475" target="_blank">Discuss this article on MousePad.</a></strong>						
					</ol>
				</div>
			</div>
			<div class="ad-holder has-margin">
					<!-- ros_footer -->
<div id='div-gpt-ad-1324422172992-25' >
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1324422172992-25'); });
</script>
</div>			</div>
		</main>
		<footer id="footer">
			<div class="footer-area">
				<div class="holder">
					<article class="col-left">
						<h2>About MousePlanet</h2>
						<p>MousePlanet is your independent consumer guide to Disney travel and vacations, covering Disneyland, Walt Disney World and the Disney Cruise Line. Look to MousePlanet for daily news, weekly theme park updates, and detailed travel and resort guides for your favorite Disney destinations. As with any endeavor of this size and complexity, we couldn't hope to succeed without the assistance of our readers. We encourage you to submit news, updates and feedback from your Disney travels.</p>
					</article>
					<article class="col-right">
						<h2>Join Our Newsletter</h2>
						<p>Subscribe to our weekly newsletter for all the latest updates.</p>


							<div class="ctct-embed-signup" style="font: 16px Helvetica Neue, Arial, sans-serif; font: 1rem Helvetica Neue, Arial, sans-serif; line-height: 1.5; -webkit-font-smoothing: antialiased;">
							   <div style="color:#5b5b5b; background-color:#146cba; border-radius:5px;">
							       <span id="success_message" style="display:none;">
							           <div style="text-align:center;"><h3>Thanks for signing up!</h3></div>
							       </span>
							       <form data-id="embedded_signup:form" class="ctct-custom-form Form" name="embedded_signup" method="POST" action="https://visitor2.constantcontact.com/api/signup">
							           <p></p>
							           <div class="email-form">
							           <!-- The following code must be included to ensure your sign-up form works properly. -->
							           <input data-id="ca:input" name="ca" value="37989a29-c267-4e1d-b2a8-6939f994d994" type="hidden">
							           <input data-id="list:input" name="list" value="1" type="hidden">
							           <input data-id="source:input" name="source" value="EFD" type="hidden">
							           <input data-id="required:input" name="required" value="list,email" type="hidden">
							           <input data-id="url:input" name="url" value="" type="hidden">
							           <p data-id="Email Address:p" > <input data-id="Email Address:input" name="email" value="" placeholder="Email Address" maxlength="80" type="text">
							           <input type="submit"  data-enabled="enabled" value="Go">
							           </div>
							       </form>
							   </div>
							</div>
							<script type='text/javascript'>
							   var localizedErrMap = {};
							   localizedErrMap['required'] = 		'This field is required.';
							   localizedErrMap['ca'] = 			'An unexpected error occurred while attempting to send email.';
							   localizedErrMap['email'] = 			'Please enter your email address in name@email.com format.';
							   localizedErrMap['birthday'] = 		'Please enter birthday in MM/DD format.';
							   localizedErrMap['anniversary'] = 	'Please enter anniversary in MM/DD/YYYY format.';
							   localizedErrMap['custom_date'] = 	'Please enter this date in MM/DD/YYYY format.';
							   localizedErrMap['list'] = 			'Please select at least one email list.';
							   localizedErrMap['generic'] = 		'This field is invalid.';
							   localizedErrMap['shared'] = 		'Sorry, we could not complete your sign-up. Please contact us to resolve this.';
							   localizedErrMap['state_mismatch'] = 'Mismatched State/Province and Country.';
								localizedErrMap['state_province'] = 'Select a state/province';
							   localizedErrMap['selectcountry'] = 	'Select a country';
							   var postURL = 'https://visitor2.constantcontact.com/api/signup';
							</script>
							<script type='text/javascript' src='https://static.ctctcdn.com/h/contacts-embedded-signup-assets/1.0.2/js/signup-form.js'></script>
						
						
						<h3>Follow us on</h3>
						<ul class="social-networks">
							<li><a class="facebook" href="https://www.facebook.com/mouseplanet">Facebook</a></li>
							<li><a class="twitter" href="https://twitter.com/MousePlanet">Twitter</a></li>
							<li><a class="youtube" href="https://www.youtube.com/user/MousePlanetVideo">YouTube</a></li>
							<li><a class="instagram" href="https://instagram.com/mouseplanet/">Instagram</a></li>
						</ul>
					</article>
					<div class="info-wrap">
						<ul class="footer-links">
							<li><a href="/misc/16/About_Us">About</a></li>
							<li><a href="/Contact">Contact Us</a></li>
							<li><a href="/misc/41/Linking_to_MousePlanet">Link to Us</a></li>
							<li><a href="/misc/40/Legal_Information__Privacy_Policy">Legal information and privacy policy </a></li>
						</ul>
						<!-- copyright of the page -->
						<span class="copyright">&copy; 2000-2020 MousePlanet</span>
					</div>
				</div>
			</div>
			<div class="footer-bottom">
				<div class="holder">
					<p>MousePlanet is not associated in any official way with the Walt Disney Company, its subsidiaries. or its affiliates. The official Disney site is available at <a class="site-link" href="https://www.disney.com" target="_blank">www.disney.com</a>. This MousePlanet Web site provides independent news articles, commentary, editorials, reviews. and guides about the Walt Disney Co. All information on this site is subject to change. Please contact destinations in advance to confirm the most up-to-date information.</p>
				</div>
			</div>
			<img src="/images/100px.png">			
		</footer>			</div>
	<!-- required stylesheets and scripts -->
	<script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/jquery/1.11.2/jquery.min.js"></script>
	<script type="text/javascript">window.jQuery || document.write('<script src="/js/jquery-1.11.2.min.js"><\/script>')</script>
	<script type="text/javascript" src="/js/jquery.main.js"></script>

	<script>$(function() {

	    var $allVideos = $("iframe[src*='//player.vimeo.com'], iframe[src*='//www.youtube.com'], object, embed"),
	    $fluidEl = $("p.phototour");

		$allVideos.each(function() {

		  $(this)
		    // jQuery .data does not work on object/embed elements
		    .attr('data-aspectRatio', this.height / this.width)
		    .removeAttr('height')
		    .removeAttr('width');

		});

		$(window).resize(function() {

		  var newWidth = $fluidEl.width();
		  $allVideos.each(function() {

		    var $el = $(this);
		    $el
		        .width(newWidth)
		        .height(newWidth * $el.attr('data-aspectRatio'));

		  });

		}).resize();
	});</script>



</body>
</html>

