

<!DOCTYPE html>
<html>
<head>
	<!-- AID: 12693 - 2020-07-03 - 100  -->

	<!-- set the encoding of your site -->
	<meta charset="utf-8">
	<!-- set the viewport width and initial-scale on mobile devices -->
	<meta name="viewport" content="width=device-width, initial-scale=1.0">
	<meta http-equiv="X-UA-Compatible" content="IE=Edge" />

	<title> Mouseplanet - My Disney Top 5 - Things I'll Miss About Splash Mountain by Chris Barry </title>

	<!-- include the site stylesheet -->
	<link media="all" rel="stylesheet" href="/css/fancybox.css" />
	<link media="all" rel="stylesheet" href="/css/all.css">

	<meta name="twitter:card" content="summary" />
	<meta name="twitter:site" content="@MousePlanet" />
	<meta name="twitter:title" content="My Disney Top 5 - Things I'll Miss About Splash Mountain" />
	<meta name="twitter:description" content="Chris ponders about what he might miss when the current version of Splash Mountain bids us farewell." />
	<meta name="twitter:image:src" content="https://www.mouseplanet.info/gallery/d/237279-2/ASD-01192016+-+12.jpg" />
	<meta property="og:url"                content="https://www.mouseplanet.com/12693/My_Disney_Top_5__Things_Ill_Miss_About_Splash_Mountain" />
	<meta property="og:type"               content="article" />
	<meta property="og:title"              content="My Disney Top 5 - Things I'll Miss About Splash Mountain" />
	<meta property="og:description"        content="Chris ponders about what he might miss when the current version of Splash Mountain bids us farewell." />
	<meta property="og:image"              content="https://www.mouseplanet.info/gallery/d/237279-2/ASD-01192016+-+12.jpg" />
	
	<link rel="image_src" href="https://www.mouseplanet.info/gallery/d/237279-2/ASD-01192016+-+12.jpg" / >	
	<link rel="alternate" type="application/rss+xml" title="RSS" href="/rss/articles_feed.xml" />

	
<script type="text/javascript">
String.prototype.trim = function() {
  return this.replace ( /^\s+|\s+$/g, "" );
};
</script>



<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-97843-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-97843-1');
</script>



<!-- Start Google Adsense Mobile Vignettes -->
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-8218384467922636",
    enable_page_level_ads: true
  });
</script>
<!-- End Google Adsense Mobile Vignettes -->



<!-- QST ADS
<script type="text/javascript">
(function() {var s=document.createElement('script'); s.type='text/javascript'; s.async=true; s.src='//qualitysocialtargeting.liqwid.net/?key=D85D-A6F1-B041-B88A';var x=document.getElementsByTagName('script')[0];x.parentNode.insertBefore(s,x);})();
</script>
END OF QST ADS -->

		
	<!-- Start Google DFP -->
	<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
	<script>
	  var googletag = googletag || {};
	  googletag.cmd = googletag.cmd || [];
	</script>
		
	<script type='text/javascript'>
		googletag.cmd.push(function() {
			
		var mapping = googletag.sizeMapping().
			addSize([980, 0], [728, 90]).addSize([640, 0], [300, 250]).build();
		var mapping1 = googletag.sizeMapping().
			addSize([980, 0], [728, 90]).addSize([640, 0], [300, 250]).build();
		var mapping2 = googletag.sizeMapping().
			addSize([980, 0], [728, 90]).addSize([640, 0], [300, 250]).build();
		var mapping3 = googletag.sizeMapping().
			addSize([980, 0], [728, 90]).addSize([640, 0], [300, 250]).build();
		var mapping4 = googletag.sizeMapping().
			addSize([980, 0], [728, 90]).addSize([640, 0], [300, 250]).build();
		var mapping5 = googletag.sizeMapping().
			addSize([980, 0], [728, 90]).addSize([640, 0], [300, 250]).build();
		var mapping6 = googletag.sizeMapping().
			addSize([980, 0], [728, 90]).addSize([640, 0], [300, 250]).build();
		var mapping7 = googletag.sizeMapping().
			addSize([980, 0], [728, 90]).addSize([640, 0], [300, 250]).build();
		var mapping8 = googletag.sizeMapping().
			addSize([980, 0], [728, 90]).addSize([640, 0], [300, 250]).build();
		var mapping9 = googletag.sizeMapping().
			addSize([980, 0], [728, 90]).addSize([640, 0], [300, 250]).build();
		var mapping10 = googletag.sizeMapping().
			addSize([980, 0], [728, 90]).addSize([640, 0], [300, 250]).build();
		var mapping11 = googletag.sizeMapping().
			addSize([980, 0], [728, 90]).addSize([640, 0], [300, 250]).build();
		var mapping12 = googletag.sizeMapping().
			addSize([980, 0], [728, 90]).addSize([640, 0], [300, 250]).build();
		var mapping13 = googletag.sizeMapping().
			addSize([980, 0], [728, 90]).addSize([640, 0], [300, 250]).build();
		
			    googletag.defineSlot('/1046630/tag_WDW_lb', [[300, 250], [728, 90]], 'div-gpt-ad-1440716678880-46').defineSizeMapping(mapping13).addService(googletag.pubads());	    googletag.defineSlot('/1046630/tag_WDW_cube', [[300, 600], [300, 250]], 'div-gpt-ad-1440716678880-45').addService(googletag.pubads());			
		googletag.defineSlot('/1046630/ros_footer', [728, 90], 'div-gpt-ad-1324422172992-25').addService(googletag.pubads());
	    googletag.pubads().enableSingleRequest();
	    googletag.enableServices();
	    googletag.pubads().collapseEmptyDivs();
	
		});
		</script>
		<!-- End Google DFP -->			
		

	<script type="text/javascript">
		$(document).ready(function() {
			var photoList = $('.phototour img');
			if (photoList.length) {
				$('meta[name="twitter:image:src"]').attr('content', photoList[0].src);
			}
		});
	</script>

</head>
<body>
	<!-- main container of all the page elements -->
	<div id="wrapper">
		

<div class="top-bar">
			<div class="top-holder">
				<ul class="social-networks">
					<li><span class="text-follow">Follow us on</span></li>
					<li><a class="facebook" href="https://www.facebook.com/mouseplanet" target="_blank">Facebook</a></li>
					<li><a class="twitter" href="https://twitter.com/MousePlanet" target="_blank">Twitter</a></li>
					<li><a class="youtube" href="https://www.youtube.com/user/MousePlanetVideo" target="_blank">Youtube</a></li>
					<li><a class="instagram" href="https://instagram.com/mouseplanet/">Instagram</a></li>
				</ul>
			</div>
		</div>
		<!-- header of the page -->
		<header id="header">
			<div class="holder">
				<!-- logo of the page -->
				<div class="logo">
					<a href="/"><img src="/mplogo.gif" alt="MousePlanet"></a>
				</div>
				<!-- main navigation of the page -->
				<nav id="nav">
					<!-- <div class="open-close"> -->
					<a href="#" class="nav-opener"><span></span></a>
					<div class="drop">
						<!-- search-form of the page -->
						<form action="/search.php" class="search-form" method="post">
							<fieldset>
								<div class="row">
									<input type="search" id="t" name="t" placeholder="Search">
									<input type="submit">
								</div>
							</fieldset>
						</form>
						<ul>
							<li>
								<a href="/articles.php">Articles</a>
							</li>
							<li><a href="/guide/1/Disneyland-Resort">Disneyland Guide</a>
								<ul class="dropmenu">
									<li><a href="/guide/1/Disneyland-Resort">Quick Facts</a></li>
									<li><a href="/tag/2/Disneyland_Resort_Update/">Resort Updates</a></li>
									<li><a href="/guide/448/Disneyland-Resort/Disneyland-Park">Disneyland</a></li>
									<li><a href="/guide/274/Disneyland-Resort/Disney-California-Adventure">Disney California Adventure</a></li>
									<li><a href="/guide/464/Disneyland-Resort/Downtown-Disney">Downtown Disney</a></li>
									<li><a href="http://mousepad.mouseplanet.com/forumdisplay.php?53-Trip-Reports-from-California">Trip Reports</a></li>
								</ul>
							</li>
							<li><a href="/guide/2/Walt-Disney-World">Walt Disney World Guide</a>
								<ul class="dropmenu">
									<li><a href="/guide/2/Walt-Disney-World">Quick Facts</a></li>
									<li><a href="/tag/101/Walt_Disney_World_Resort_Update/">Resort Updates</a></li>
									<li><a href="/guide/550/Walt-Disney-World/Magic-Kingdom">Magic Kingdom</a></li>
									<li><a href="/guide/303/Walt-Disney-World/Epcot">Epcot</a></li>
									<li><a href="/guide/436/Walt-Disney-World/Disneys-Hollywood-Studios">Disney's Hollywood Studios</a></li>
									<li><a href="/guide/15/Walt-Disney-World/Disneys-Animal-Kingdom">Disney's Animal Kingdom</a></li>
									<li><a href="/guide/395/Walt-Disney-World/Downtown-Disney">Downtown Disney / Disney Springs</a></li>
									<li><a href="http://mousepad.mouseplanet.com/forumdisplay.php?54-Trip-Reports-from-Floridaa">Trip Reports</a></li>
								</ul>
							</li>
							<li><a href="http://mousepad.mouseplanet.com">Forum</a></li>
						</ul>
					</div>
					<!-- </div> -->
				</nav>
			</div>
		</header>		<!-- contain main informative part of the site -->
		<main id="main" role="main">
			<div class="holder padding">
				<div class="ad-holder">
					<!-- /1046630/tag_WDW_lb -->
<div id='div-gpt-ad-1440716678880-46'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1440716678880-46'); });
</script>
</div>				</div>

				<div class="heading">
										<h1>My Disney Top 5 - Things I'll Miss About Splash Mountain</h1>
					
											by <a href="/author/44/Chris_Barry/" class="name">Chris Barry</a>, contributing writer						<a href="/contact/w/44/Chris-Barry" title='Send Chris Barry an email'><img src="/images/mail.png" height="20"></a>
										<time datetime="2020-07-03">July 3, 2020</time>
				</div>

				<div class="content-holder">
					<div class="ad-block">
						<h6>Advertisement</h6>
						<div class="ad-holder">
							<!-- /1046630/tag_WDW_cube -->
<div id='div-gpt-ad-1440716678880-45'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1440716678880-45'); });
</script>
</div>						</div>
					</div>
					<div class="text-holder">
						<p>Welcome back to another Disney Top 5. I hope all of you are staying safe and healthy out there.</p>

<p>I've always been an advocate of Walt Disney's credo, "Disneyland will never be completed. It will continue to grow as long as there is imagination left in the world." I've certainly stood by that motto when it comes to changes both major and minor in the Disney parks. Over the years, I've definitely lamented some changes to Walt Disney World. I think I'm in the minority here but I felt pretty bad when Snow Whites Scary Adventures closed. It was hard to get more classic than that. Wishes was a big loss for everyone in this household, even though its replacement, Happily Ever After is pretty amazing. My daughter and I were sorry to see Maelstrom shut down and made sure to catch one of the final rides before it closed. My sons and I were there for the final illuminations this past fall and I know I'm going to miss that spectacular show no matter what they replace it with. And don't even get me started on Spectromagic going away for good. As Disney fans we do grow attached to our attractions, our restaurants, our characters and even small details in the parks that we find endearing. When they go away or are changed, it's almost personal. But if you believed in what Walt was trying to do with his parks than you have to accept the changes.</p>

<p>Typically, as I noted above, I like to give the Imagineers some credit and see what they come up with when they decide to retire attractions. For example, my daughter was borderline irate when The Great Movie Ride shut down. Personally, I'd seen it enough and was ready for what the Imagineers were billing as a 'game changing attraction" to take its place. I guess we'll see about that when I finally get to board Mickey and Minnie's Runaway Railway someday. My feelings have always been, "As long as the Imagineers are putting a great amount of thought, creativity and solid storytelling into what they're doing, then I'm ready to see what they come up with. " The results have usually been pretty good. Despite some heavy Frozen saturation just about everywhere in the Disney universe, I think they did a nice job with Anna and Elsa in Norway. I was fine with the the Three Caballeros being added to Mexico and Nemo taking over the Seas pavilion. I loved the original film in Soarin' and love the second version just as much. I can say the same thing about Test Track and I can't wait to someday ride the Guardians of the Galaxy coaster and had no problem bidding Ellen and Bill Nye farewell. And if you know me well enough, you'd know that I practically threw a party when I heard they were going to bulldoze Lights, Motors, Action, the Backlot and the Streets of America in order to build Galaxy's Edge. That was a win win on all accounts!</p>

<p>So the question is, "How am I feeling about Splash Mountain going away and being replaced with <em>The Princess and the Frog</em>?" Well, this one is not so clear cut for me. I'm a big Splash Mountain fan and the loss of one of Disney's signature attractions, not to mention a personal favorite hasn't been such an easy pill to swallow. My daughter? Big <em>Princess and the Frog</em> fan and she's waiting with unbridled excitement to see what the Imagineers come up with to replace Chickapin Hill. I actually haven't watched Princess and the Frog since I saw it in the theaters when it was released. I couldn't wait to see a return to 2D animation and loved what I saw and heard on the big screen that night, so I do have a great amount of hope that something wonderful could take place with the retheming of Splash Mountain. I plan on watching <em>Princess and the Frog</em> again this week to build up some excitement and start to get some visions of what they could do once Brer Rabbit and his animal friends move out.</p>

<p>Before I go forward lamenting its departure, let's address the elephant in the room when it comes to this Disney classic attraction. Prior to me sitting down to write this article, I sat myself down and rewatched <em>Song of the South</em>, a film that I haven't watched in years. And before you ask, yes I own a copy. I managed to get my hands on a PAL VHS tape from the United Kingdom probably around 15-20 years ago. In my other life as a TV production teacher, I had a PAL converter in my studio. For those of you who are unaware, back then when it came to videotapes, the world was broken up into regions. You couldn't watch a tape from Europe, which used the PAL format, here in the states and vice versa. Not unless you had a converter deck like we had in the studio. I had seen the film as a kid and it was really one of the only holes in my Disney library and when I stumbled upon a PAL copy, which would be useless to most people, I snatched it up to be a completist.</p>

<p>So, after watching it again the other evening, yes, I get it. It's got issues. No doubt about it. The stereotyped characters and dialogue are a bit unsettling to say the least. The setting isn't really conveyed clearly to the audience either. Is this during the time of slavery and I'm watching happy singing slaves? Or is it post Civil War and they are free, but yet still undeniably working for the rich white plantation owner? Turns out it's the latter, but a lot of people have thought it to be the former and, yes, if you think you're watching a group of African Americans singing happy songs while they are enslaved&nbsp;you would come away thinking how unlikely that scenario would have been and how pretty despicable of an interpretation that was. So, there's definitely some misunderstanding with <em>Song of the South</em> and how it presents itself. There's also the point of view that writer Joel Chandler, who was white, took these African American folktales and went and made money with them. Was he enchanted with these charming tales and published them in homage so they could be read for generations? Or was he capitalizing on them? That's an age old argument for sure. Should I throw away my Elvis and Rolling Stones albums because they took everything from black music and made it there own or were they devoted fans paying homage to the music they loved the most?</p>

<p>The sad part about all of this is that the underlying story of <em>Song of the South</em> is that of a wealthy young white boy who comes to stay at the plantation while his parents seem to be separating and how he finds solace and happiness in the stories of an old, Black storyteller named Uncle Remus. They are an unlikely pair, especially when you consider this film was made in 1946. The friendship and bonds that develop and the fact that these two polar opposites essentially save each other in the end is undeniably not a racist storyline. In fact their relationship in the film is the complete opposite with little Johnny referring to Uncle Remus as his best friend in the whole world.</p>

<p>So, it's a shame that <em>Song of the South</em> is viewed by some as a racist film. My personal opinion is, no, it's not a racist film. Is it a flawed film and a product of an unenlightened time? Yes, for sure. From a filmmaking point of view, the blend of live action and animation is groundbreaking. The songs are wonderful and it features performances by Hattie McDaniel, who was the first African American actor to win an Oscar for her role in another troubled yet legendary film, <em>Gone With the Wind</em>, and James Baskett as Uncle Remus in a role that won him an honorary Oscar as well. There are definitely troubling aspects to the film. I'd be a fool to deny that. Should it be swept under the carpet and locked in a fault? In my personal opinion, the answer to that question is, "No." It should be watched, discussed and learned from rather than cast aside.</p>

<p>As far as the ride is concerned, in this writer's opinion, on the surface it's pretty harmless. Once again, the underlying story seems to be getting lost in the hoopla. The Imagineers chose to tell the story of Brer Rabbit from the film's animated sequences. The young rabbit yearns to leave his home behind, gets chased and nearly eaten by the villains, Brer Bear and Brer Fox, and then outsmarts them and decides that his home is a pretty wonderful place and therefore he'll stay much to the delight of all of his animal neighbors. There's wisely no reference to Uncle Remus, the plantation nor any of the human characters from the film. The ride itself is a wonderful collection of animatronic animals, scenery, music and mayhem culminating in the famous drop over the falls. It's beautifully done, full of rich details throughout and aesthetically speaking, it may be one of the best things that Disney has ever done. Which of those details will I miss? Let's take a look at my Top 5 things I'm going to miss about Splash Mountain.</p>

<h3>5 - The Opossums</h3>

<p>Yeah. This is a strange choice, but I have to say, out of all of the animatronic characters from the ride, I've always loved these opossums hanging from the tree deep inside the ride. Once again, it's a Disney park fan thing. My daughter loves the dog wagging his tongue in the Polynesia room of it's a small world and I love these silly little creatures over in Splash Mountain.</p>

<p><p class="phototour"><a title="The sad thing is I don't even have a photo of my favorite little opossums from Splash Mountain! &copy;Disney" rel="lightbox" href="https://www.mouseplanet.info/gallery/d/314493-1/Splash+Characters.jpg"><img width="400" height="227" border="0" alt="" src="https://www.mouseplanet.info/gallery/d/314497-2/Splash+Characters.jpg"></a><br>The sad thing is I don't even have a photo of my favorite little opossums from Splash Mountain! &copy;Disney</p></p>

<p>My hope is that this trio of marsupials are snuck into the <em>Princess and the Frog </em>scenes in the new ride as one of the Imagineers little homages to the past attraction. If not, if they somehow ever got auctioned off - which I can't imagine would happen - well then my wife should be prepared for them to be hanging from the ceiling in our family room!</p>

<h3>4 - The Secondary Characters</h3>

<p>One of the things I've always liked about walking through the queue is seeing some of the other Brer animals that you'll eventually see throughout the ride. You can find Brer Frog and Brer Goose in the line right before you approach the flume boarding area. Then in the ride, there's plenty more like Brer Porky Pine, Brer Tortoise, Mr. Bluebird and even Brer Roadrunner. By the way, I'm pretty sure there are no roadrunners in the bayou but I've always been willing to overlook that.</p>

<p><p class="phototour"><a title="The elusive Brer Roadrunner may soon go the way of the dodo. &copy;Disney" rel="lightbox" href="https://www.mouseplanet.info/gallery/d/335126-1/Screen+Shot+2020-07-02+at+12_01_03+AM_001.jpg"><img width="400" height="300" border="0" alt="" src="https://www.mouseplanet.info/gallery/d/335128-2/Screen+Shot+2020-07-02+at+12_01_03+AM_001.jpg"></a><br>The elusive Brer Roadrunner may soon go the way of the dodo. &copy;Disney</p></p>

<p>These secondary characters are almost certain to be put into storage and never seen again and that's a shame. I hope a few make the transition into the background somewhere. The frogs should be easy enough to keep around with Tiana and Naveen. Perhaps some of the others can be moved over to Walt Disney Presents in the Studios or maybe they can do something with them over at Port Orleans Riverside or in some other attraction somewhere, especially considering the fact that a lot of them were from America Sings in Disneyland.</p>

<h3>3 - The Zip A Dee Lady</h3>

<p>For those of you that don't obsess over the details in Walt Disney World attractions, the Zip a Dee Lady is the name of the riverboat that comes into view as you reenter Splash Mountain after the big drop down the falls. It's always been one of my favorite "reveals" in a Disney park. Just when you thought you were at the end of a very long attraction, the Imagineers conclude the story with a big finish.</p>

<p><p class="phototour"><a title="The big reveal near the end of Splash Mountain featuring a dozen or so singing animatronics. &copy;Disney" rel="lightbox" href="https://www.mouseplanet.info/gallery/d/314333-1/Zip-Dee-Lady.jpg"><img width="400" height="276" border="0" alt="" src="https://www.mouseplanet.info/gallery/d/314337-2/Zip-Dee-Lady.jpg"></a><br>The big reveal near the end of Splash Mountain featuring a dozen or so singing animatronics. &copy;Disney</p></p>

<p>The boat is loaded with singing animals welcoming Brer Rabbit back home as they sing the award winning song, Zip-a-Dee-Doo-Dah. It's a fun moment and one that has always personified just how far the Imagineers always go to add details and drive home the storyline. They didn't have to add this room. The big ending could have been the drop and then you disembark, but they threw this giant room in and it's the perfect ending to the ride. I'm hoping they can keep the riverboat. It could easily fit in to the storyline and locations of <em>Princess and the Frog.</em></p>

<h3>2 - The Music</h3>

<p>One thing you can't deny is that the music in Splash Mountain is catchy and it gets into your head. Case in point, I took a break from writing this to help get dinner ready and I was whistling "How Do You Do" the entire time. Couldn't get it out of my head. We went out for a walk afterwards as a family and my daughter said, "Now you've got me singing that Splash Mountain song!" Couple that song with "Everybody's Got a Laughing Place" and "Zip-A-Dee-Doo-Dah" and it's hard to walk out of that ride not singing something.</p>

<p><p class="phototour"><a title="As you get closer to Chickapin Hill you start to hear the banjo and harmonica music of the bayou. Photo by Donald Fink." rel="lightbox" href="https://www.mouseplanet.info/gallery/d/244846-2/18-DLF7200431-Edit.jpg"><img width="300" height="400" border="0" alt="" src="https://www.mouseplanet.info/gallery/d/244850-2/18-DLF7200431-Edit.jpg"></a><br>As you get closer to Chickapin Hill you start to hear the banjo and harmonica music of the bayou. Photo by Donald Fink.</p></p>

<p>I'm even a big fan of the banjo and harmonica instrumental music you hear during your time in the queue. It sets the mood perfectly and I'll miss hearing those songs on my future visits to Walt Disney World for sure.</p>

<h3>1 - The Brers</h3>

<p>Here's the thing. I like the three main characters, Brer Bear, Brer Fox and Brer Rabbit quite a bit. I have memories of them from my childhood when I just enjoyed them as what they were, a rabbit, a fox and a bear, not some controversial characters from a troubled film. What did I know? I know my own children have Brer Rabbit plush toys, little figurines we bought in the parks and that toy log flume vehicle that they used to play with. So, when Splash Mountain goes away, will these three classic characters go with it? After all, as I said above, I'm quite sure that the vast majority of guests know them from the attraction, not from the film. So, if the film is essentially gone and then the attraction is officially gone, what's to become of these three characters?</p>

<p><p class="phototour"><a title="I'd love to have these wood carvings in my yard once the attraction undergoes its makeover. Photo by Brian Bennett." rel="lightbox" href="https://www.mouseplanet.info/gallery/d/27623-2/SM_brer_fox_bear_and_rabbit_bennett.jpg"><img width="300" height="400" border="0" alt="" src="https://www.mouseplanet.info/gallery/d/197034-2/SM_brer_fox_bear_and_rabbit_bennett.jpg"></a><br>I'd love to have these wood carvings in my yard once the attraction undergoes its makeover. Photo by Brian Bennett.</p></p>

<p>Will they still be walking around during the parades or will they just fade away? Should they just fade away? Are they relics from a different age that will no longer have a place in the modern day Disney experience? I hope not. Actually, I'd like to see them come back maybe in an animated short form somehow. These characters have a history in African American folktales. Maybe something can be done with them now that honors that heritage. At any rate, I'm glad that I finally got to take a photo with Brer Rabbit at the Magic Kingdom this fall. I was chasing that meet and greet for years and finally spotted him walking through Frontierland during the Halloween party and snapped this photo.</p>

<p><p class="phototour"><a title="My son Alex and I ran into Brer Rabbit in Frontierland after 16 years of searching. Photo by Casey Barry." rel="lightbox" href="https://www.mouseplanet.info/gallery/d/326516-1/Bre+Rabbit.jpg"><img width="300" height="400" border="0" alt="" src="https://www.mouseplanet.info/gallery/d/326520-2/Bre+Rabbit.jpg"></a><br>My son Alex and I ran into Brer Rabbit in Frontierland after 16 years of searching. Photo by Casey Barry.</p></p>

<p>It might have been the last chance I got to take a photo with one of my favorite childhood characters. And let's remember, he was a favorite character of mine because he was just a silly rabbit who outsmarted the dopey bullies who were chasing him. That's why I loved him. Not because of his association with an outdated and problematic movie.</p>

<p>The question then becomes, should Splash Mountain really go away because of its association with the film? That's a tougher question than I'm actually ready to completely tackle in this piece. I'd venture to guess that more than 95% of the guests going over the falls have never seen, nor probably ever will see the original film. I'd actually go a step further and say that most guests don't even know of the existence of <em>Song of the South</em> at all. Some people would say that that's the problem. The argument can be made that the popularity of the attraction kind of ignores the fact that it is derived from a controversial film that Disney doesn't even want to be seen by the public so why have a headlining attraction based on that film? That's a pretty solid argument. A friend of mine weighed in saying that he's never seen the film, just about nobody knows the film, so why not turn it into something that the modern audience can connect to, like <em>Princess and the Frog</em>? That's a pretty simplistic view, but it's also hard to argue with the logic.</p>

<p>The questions are all moot though, because Splash Mountain is going away. The bones of the ride and the famous drop will all still be there. It'll still be a headliner. Only now, it'll pay homage to a newer film, one that this generation knows and loves and it's an important film at that. Tiana, Naveen and Louis are moving in. Bre Rabbit, Brer Bear and Brer Fox are moving out. Walt's credo is being followed. Change is inevitable. I'm looking forward to seeing what the Imagineers bring us. I'm expecting a wonderful soundtrack, some beautiful scenery and I'm fully expecting to be dazzled by a room full of fireflies! With any luck, I'll get one last ride on Splash Mountain someday, but if not, it gave me plenty of smiles and thrills over the years. Change is good. Evolution is good. It's up to Disney's Imagineers now to dazzle us with an awesome <em>Princess and the Frog</em> attraction to make me feel OK about losing Brer Rabbit. I've got faith in them. Dare I say, despite missing the above things from Splash Mountain, I'm pretty sure that everything will tun out to be...satisfactual!</p>

<p>That's my take on Splash Mountain going away. As always I'd like to hear what you have to say. Click on the link below, share your thoughts and whether or not you'll miss anything from Chickapin Hill and I'll see you next time with another Disney Top 5.</p>
<p>&nbsp</p>
					<p>
						<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
						<ins class="adsbygoogle"
						     style="display:block"
						     data-ad-format="autorelaxed"
						     data-ad-client="ca-pub-8218384467922636"
						     data-ad-slot="7483507399"></ins>
						<script>
						     (adsbygoogle = window.adsbygoogle || []).push({});
						</script>

					</p>

					</div>
				<div class="social-block">
					<div class="info-share">
						<h4>Share this article</h4>
							<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-514bcc3157fb0a34" async="async"></script>
							<div class="addthis_sharing_toolbox"></div>
					</div>
					<div class="info-tag">
						<h4>Tags</h4>
						<ul class="list-tags">
							<li><a href="/tag/100/Walt_Disney_World_Resort/">Walt Disney World Resort</a></li><li><a href="/tag/1108/Frontierland/">Frontierland</a></li><li><a href="/tag/102/Magic_Kingdom/">Magic Kingdom</a></li><li><a href="/tag/1260/Splash_Mountain/">Splash Mountain</a></li>						</ul>
					</div>
				</div>

				<article class="article-info">
					<h4>Similar Articles</h4>
					<ul class="list-articles">

							<li>	<a href="/12681/My_Disney_Top_5__Things_My_Family_Wants_To_Do_First_If_We_Could_Go_To_Walt_Disney_World_Tomorrow" class="img-holder">	<img src=" https://www.mouseplanet.info/gallery/d/229037-2/ASD-08222015+-+9.jpg" alt="My Disney Top 5 - Things My Family Wants To Do First If We Could Go To Walt Disney World Tomorrow." width="261" height="193"></a>	<a href="/12681/My_Disney_Top_5__Things_My_Family_Wants_To_Do_First_If_We_Could_Go_To_Walt_Disney_World_Tomorrow" class="title">My Disney Top 5 - Things My Family Wants To Do First If We Could Go To Walt Disney World Tomorrow.</a>	<br /><span class="author">by <a href="/12681/My_Disney_Top_5__Things_My_Family_Wants_To_Do_First_If_We_Could_Go_To_Walt_Disney_World_Tomorrow" class="name">Chris Barry</a> <time datetime="2020-06-19">June 19, 2020</time></span>  </li><li>	<a href="/12669/Things_We_Miss_About_Walt_Disney_World_Part_2" class="img-holder">	<img src=" https://www.mouseplanet.info/gallery/d/334803-2/101-Slinky+Dog.jpg" alt="Things We Miss About Walt Disney World: Part 2" width="261" height="193"></a>	<a href="/12669/Things_We_Miss_About_Walt_Disney_World_Part_2" class="title">Things We Miss About Walt Disney World: Part 2</a>	<br /><span class="author">by <a href="/12669/Things_We_Miss_About_Walt_Disney_World_Part_2" class="name">Donald and Bonnie Fink</a> <time datetime="2020-06-11">June 11, 2020</time></span>  </li><li>	<a href="/12666/My_Disney_Top_5__Walt_Disney_World_Restaurants_My_Family_Would__To_Like_Be_At_Right_Now" class="img-holder">	<img src=" https://www.mouseplanet.info/gallery/d/297997-2/111-Biergarten+Restaurant.jpg" alt="My Disney Top 5 - Walt Disney World Restaurants My Family Would  To Like Be At Right Now" width="261" height="193"></a>	<a href="/12666/My_Disney_Top_5__Walt_Disney_World_Restaurants_My_Family_Would__To_Like_Be_At_Right_Now" class="title">My Disney Top 5 - Walt Disney World Restaurants My Family Would  To Like Be At Right Now</a>	<br /><span class="author">by <a href="/12666/My_Disney_Top_5__Walt_Disney_World_Restaurants_My_Family_Would__To_Like_Be_At_Right_Now" class="name">Chris Barry</a> <time datetime="2020-06-05">June 5, 2020</time></span>  </li>


					</ul>					
				</article>
			</div>

			<div class="comment-block">
				<div class="holder">
					<h2>Comments</h2>
					<ol class="list-comments">

						<li><strong class="comment-info"><a href="https://mousepad.mouseplanet.com/showthread.php?t=300223" target="_blank">Discuss this article on MousePad.</a></strong>						
					</ol>
				</div>
			</div>
			<div class="ad-holder has-margin">
					<!-- ros_footer -->
<div id='div-gpt-ad-1324422172992-25' >
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1324422172992-25'); });
</script>
</div>			</div>
		</main>
		<footer id="footer">
			<div class="footer-area">
				<div class="holder">
					<article class="col-left">
						<h2>About MousePlanet</h2>
						<p>MousePlanet is your independent consumer guide to Disney travel and vacations, covering Disneyland, Walt Disney World and the Disney Cruise Line. Look to MousePlanet for daily news, weekly theme park updates, and detailed travel and resort guides for your favorite Disney destinations. As with any endeavor of this size and complexity, we couldn't hope to succeed without the assistance of our readers. We encourage you to submit news, updates and feedback from your Disney travels.</p>
					</article>
					<article class="col-right">
						<h2>Join Our Newsletter</h2>
						<p>Subscribe to our weekly newsletter for all the latest updates.</p>


							<div class="ctct-embed-signup" style="font: 16px Helvetica Neue, Arial, sans-serif; font: 1rem Helvetica Neue, Arial, sans-serif; line-height: 1.5; -webkit-font-smoothing: antialiased;">
							   <div style="color:#5b5b5b; background-color:#146cba; border-radius:5px;">
							       <span id="success_message" style="display:none;">
							           <div style="text-align:center;"><h3>Thanks for signing up!</h3></div>
							       </span>
							       <form data-id="embedded_signup:form" class="ctct-custom-form Form" name="embedded_signup" method="POST" action="https://visitor2.constantcontact.com/api/signup">
							           <p></p>
							           <div class="email-form">
							           <!-- The following code must be included to ensure your sign-up form works properly. -->
							           <input data-id="ca:input" name="ca" value="37989a29-c267-4e1d-b2a8-6939f994d994" type="hidden">
							           <input data-id="list:input" name="list" value="1" type="hidden">
							           <input data-id="source:input" name="source" value="EFD" type="hidden">
							           <input data-id="required:input" name="required" value="list,email" type="hidden">
							           <input data-id="url:input" name="url" value="" type="hidden">
							           <p data-id="Email Address:p" > <input data-id="Email Address:input" name="email" value="" placeholder="Email Address" maxlength="80" type="text">
							           <input type="submit"  data-enabled="enabled" value="Go">
							           </div>
							       </form>
							   </div>
							</div>
							<script type='text/javascript'>
							   var localizedErrMap = {};
							   localizedErrMap['required'] = 		'This field is required.';
							   localizedErrMap['ca'] = 			'An unexpected error occurred while attempting to send email.';
							   localizedErrMap['email'] = 			'Please enter your email address in name@email.com format.';
							   localizedErrMap['birthday'] = 		'Please enter birthday in MM/DD format.';
							   localizedErrMap['anniversary'] = 	'Please enter anniversary in MM/DD/YYYY format.';
							   localizedErrMap['custom_date'] = 	'Please enter this date in MM/DD/YYYY format.';
							   localizedErrMap['list'] = 			'Please select at least one email list.';
							   localizedErrMap['generic'] = 		'This field is invalid.';
							   localizedErrMap['shared'] = 		'Sorry, we could not complete your sign-up. Please contact us to resolve this.';
							   localizedErrMap['state_mismatch'] = 'Mismatched State/Province and Country.';
								localizedErrMap['state_province'] = 'Select a state/province';
							   localizedErrMap['selectcountry'] = 	'Select a country';
							   var postURL = 'https://visitor2.constantcontact.com/api/signup';
							</script>
							<script type='text/javascript' src='https://static.ctctcdn.com/h/contacts-embedded-signup-assets/1.0.2/js/signup-form.js'></script>
						
						
						<h3>Follow us on</h3>
						<ul class="social-networks">
							<li><a class="facebook" href="https://www.facebook.com/mouseplanet">Facebook</a></li>
							<li><a class="twitter" href="https://twitter.com/MousePlanet">Twitter</a></li>
							<li><a class="youtube" href="https://www.youtube.com/user/MousePlanetVideo">YouTube</a></li>
							<li><a class="instagram" href="https://instagram.com/mouseplanet/">Instagram</a></li>
						</ul>
					</article>
					<div class="info-wrap">
						<ul class="footer-links">
							<li><a href="/misc/16/About_Us">About</a></li>
							<li><a href="/Contact">Contact Us</a></li>
							<li><a href="/misc/41/Linking_to_MousePlanet">Link to Us</a></li>
							<li><a href="/misc/40/Legal_Information__Privacy_Policy">Legal information and privacy policy </a></li>
						</ul>
						<!-- copyright of the page -->
						<span class="copyright">&copy; 2000-2020 MousePlanet</span>
					</div>
				</div>
			</div>
			<div class="footer-bottom">
				<div class="holder">
					<p>MousePlanet is not associated in any official way with the Walt Disney Company, its subsidiaries. or its affiliates. The official Disney site is available at <a class="site-link" href="https://www.disney.com" target="_blank">www.disney.com</a>. This MousePlanet Web site provides independent news articles, commentary, editorials, reviews. and guides about the Walt Disney Co. All information on this site is subject to change. Please contact destinations in advance to confirm the most up-to-date information.</p>
				</div>
			</div>
			<img src="/images/100px.png">			
		</footer>			</div>
	<!-- required stylesheets and scripts -->
	<script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/jquery/1.11.2/jquery.min.js"></script>
	<script type="text/javascript">window.jQuery || document.write('<script src="/js/jquery-1.11.2.min.js"><\/script>')</script>
	<script type="text/javascript" src="/js/jquery.main.js"></script>

	<script>$(function() {

	    var $allVideos = $("iframe[src*='//player.vimeo.com'], iframe[src*='//www.youtube.com'], object, embed"),
	    $fluidEl = $("p.phototour");

		$allVideos.each(function() {

		  $(this)
		    // jQuery .data does not work on object/embed elements
		    .attr('data-aspectRatio', this.height / this.width)
		    .removeAttr('height')
		    .removeAttr('width');

		});

		$(window).resize(function() {

		  var newWidth = $fluidEl.width();
		  $allVideos.each(function() {

		    var $el = $(this);
		    $el
		        .width(newWidth)
		        .height(newWidth * $el.attr('data-aspectRatio'));

		  });

		}).resize();
	});</script>



</body>
</html>

