

<!DOCTYPE html>
<html>
<head>
	<!-- AID: 12876 - 2021-03-02 - 101  -->

	<!-- set the encoding of your site -->
	<meta charset="utf-8">
	<!-- set the viewport width and initial-scale on mobile devices -->
	<meta name="viewport" content="width=device-width, initial-scale=1.0">
	<meta http-equiv="X-UA-Compatible" content="IE=Edge" />

	<title> Mouseplanet - Walt Disney World Resort Update for March 2-8, 2021 by Alan S. Dalinka </title>

	<!-- include the site stylesheet -->
	<link media="all" rel="stylesheet" href="/css/fancybox.css" />
	<link media="all" rel="stylesheet" href="/css/all.css">

	<meta name="twitter:card" content="summary" />
	<meta name="twitter:site" content="@MousePlanet" />
	<meta name="twitter:title" content="Walt Disney World Resort Update for March 2-8, 2021" />
	<meta name="twitter:description" content="Ranger the white rhino debuts at Disney's Animal Kingdom (and gets attention); Taste of EPCOT International Flower & Garden Festival Begins Tomorrow (with more live entertainment on the way); Disney Parks celebrates Women's History Month" />
	<meta name="twitter:image:src" content="https://www.mouseplanet.info/gallery/d/340316-2/ASD-DAK-02-23-2021+-+21.jpeg" />
	<meta property="og:url"                content="https://www.mouseplanet.com/12876/Walt_Disney_World_Resort_Update_for_March_28_2021" />
	<meta property="og:type"               content="article" />
	<meta property="og:title"              content="Walt Disney World Resort Update for March 2-8, 2021" />
	<meta property="og:description"        content="Ranger the white rhino debuts at Disney's Animal Kingdom (and gets attention); Taste of EPCOT International Flower & Garden Festival Begins Tomorrow (with more live entertainment on the way); Disney Parks celebrates Women's History Month" />
	<meta property="og:image"              content="https://www.mouseplanet.info/gallery/d/340316-2/ASD-DAK-02-23-2021+-+21.jpeg" />
	
	<link rel="image_src" href="https://www.mouseplanet.info/gallery/d/340316-2/ASD-DAK-02-23-2021+-+21.jpeg" / >	
	<link rel="alternate" type="application/rss+xml" title="RSS" href="/rss/articles_feed.xml" />

	
<script type="text/javascript">
String.prototype.trim = function() {
  return this.replace ( /^\s+|\s+$/g, "" );
};
</script>



<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-97843-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-97843-1');
</script>



<!-- Start Google Adsense Mobile Vignettes -->
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-8218384467922636",
    enable_page_level_ads: true
  });
</script>
<!-- End Google Adsense Mobile Vignettes -->



<!-- QST ADS
<script type="text/javascript">
(function() {var s=document.createElement('script'); s.type='text/javascript'; s.async=true; s.src='//qualitysocialtargeting.liqwid.net/?key=D85D-A6F1-B041-B88A';var x=document.getElementsByTagName('script')[0];x.parentNode.insertBefore(s,x);})();
</script>
END OF QST ADS -->

		
	<!-- Start Google DFP -->
	<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
	<script>
	  var googletag = googletag || {};
	  googletag.cmd = googletag.cmd || [];
	</script>
		
	<script type='text/javascript'>
		googletag.cmd.push(function() {
			
		var mapping = googletag.sizeMapping().
			addSize([980, 0], [728, 90]).addSize([640, 0], [300, 250]).build();
		var mapping1 = googletag.sizeMapping().
			addSize([980, 0], [728, 90]).addSize([640, 0], [300, 250]).build();
		var mapping2 = googletag.sizeMapping().
			addSize([980, 0], [728, 90]).addSize([640, 0], [300, 250]).build();
		var mapping3 = googletag.sizeMapping().
			addSize([980, 0], [728, 90]).addSize([640, 0], [300, 250]).build();
		var mapping4 = googletag.sizeMapping().
			addSize([980, 0], [728, 90]).addSize([640, 0], [300, 250]).build();
		var mapping5 = googletag.sizeMapping().
			addSize([980, 0], [728, 90]).addSize([640, 0], [300, 250]).build();
		var mapping6 = googletag.sizeMapping().
			addSize([980, 0], [728, 90]).addSize([640, 0], [300, 250]).build();
		var mapping7 = googletag.sizeMapping().
			addSize([980, 0], [728, 90]).addSize([640, 0], [300, 250]).build();
		var mapping8 = googletag.sizeMapping().
			addSize([980, 0], [728, 90]).addSize([640, 0], [300, 250]).build();
		var mapping9 = googletag.sizeMapping().
			addSize([980, 0], [728, 90]).addSize([640, 0], [300, 250]).build();
		var mapping10 = googletag.sizeMapping().
			addSize([980, 0], [728, 90]).addSize([640, 0], [300, 250]).build();
		var mapping11 = googletag.sizeMapping().
			addSize([980, 0], [728, 90]).addSize([640, 0], [300, 250]).build();
		var mapping12 = googletag.sizeMapping().
			addSize([980, 0], [728, 90]).addSize([640, 0], [300, 250]).build();
		var mapping13 = googletag.sizeMapping().
			addSize([980, 0], [728, 90]).addSize([640, 0], [300, 250]).build();
		
			    googletag.defineSlot('/1046630/wdw_pu_lb', [[300, 250], [728, 90]], 'div-gpt-ad-1324422172992-34').defineSizeMapping(mapping9).addService(googletag.pubads());	    googletag.defineSlot('/1046630/wdw_pu_cube', [[300, 600], [300, 250]], 'div-gpt-ad-1324422172992-33').addService(googletag.pubads());			
		googletag.defineSlot('/1046630/ros_footer', [728, 90], 'div-gpt-ad-1324422172992-25').addService(googletag.pubads());
	    googletag.pubads().enableSingleRequest();
	    googletag.enableServices();
	    googletag.pubads().collapseEmptyDivs();
	
		});
		</script>
		<!-- End Google DFP -->			
		

	<script type="text/javascript">
		$(document).ready(function() {
			var photoList = $('.phototour img');
			if (photoList.length) {
				$('meta[name="twitter:image:src"]').attr('content', photoList[0].src);
			}
		});
	</script>

</head>
<body>
	<!-- main container of all the page elements -->
	<div id="wrapper">
		

<div class="top-bar">
			<div class="top-holder">
				<ul class="social-networks">
					<li><span class="text-follow">Follow us on</span></li>
					<li><a class="facebook" href="https://www.facebook.com/mouseplanet" target="_blank">Facebook</a></li>
					<li><a class="twitter" href="https://twitter.com/MousePlanet" target="_blank">Twitter</a></li>
					<li><a class="youtube" href="https://www.youtube.com/user/MousePlanetVideo" target="_blank">Youtube</a></li>
					<li><a class="instagram" href="https://instagram.com/mouseplanet/">Instagram</a></li>
				</ul>
			</div>
		</div>
		<!-- header of the page -->
		<header id="header">
			<div class="holder">
				<!-- logo of the page -->
				<div class="logo">
					<a href="/"><img src="/mplogo.gif" alt="MousePlanet"></a>
				</div>
				<!-- main navigation of the page -->
				<nav id="nav">
					<!-- <div class="open-close"> -->
					<a href="#" class="nav-opener"><span></span></a>
					<div class="drop">
						<!-- search-form of the page -->
						<form action="/search.php" class="search-form" method="post">
							<fieldset>
								<div class="row">
									<input type="search" id="t" name="t" placeholder="Search">
									<input type="submit">
								</div>
							</fieldset>
						</form>
						<ul>
							<li>
								<a href="/articles.php">Articles</a>
							</li>
							<li><a href="/guide/1/Disneyland-Resort">Disneyland Guide</a>
								<ul class="dropmenu">
									<li><a href="/guide/1/Disneyland-Resort">Quick Facts</a></li>
									<li><a href="/tag/2/Disneyland_Resort_Update/">Resort Updates</a></li>
									<li><a href="/guide/448/Disneyland-Resort/Disneyland-Park">Disneyland</a></li>
									<li><a href="/guide/274/Disneyland-Resort/Disney-California-Adventure">Disney California Adventure</a></li>
									<li><a href="/guide/464/Disneyland-Resort/Downtown-Disney">Downtown Disney</a></li>
									<li><a href="http://mousepad.mouseplanet.com/forumdisplay.php?53-Trip-Reports-from-California">Trip Reports</a></li>
								</ul>
							</li>
							<li><a href="/guide/2/Walt-Disney-World">Walt Disney World Guide</a>
								<ul class="dropmenu">
									<li><a href="/guide/2/Walt-Disney-World">Quick Facts</a></li>
									<li><a href="/tag/101/Walt_Disney_World_Resort_Update/">Resort Updates</a></li>
									<li><a href="/guide/550/Walt-Disney-World/Magic-Kingdom">Magic Kingdom</a></li>
									<li><a href="/guide/303/Walt-Disney-World/Epcot">Epcot</a></li>
									<li><a href="/guide/436/Walt-Disney-World/Disneys-Hollywood-Studios">Disney's Hollywood Studios</a></li>
									<li><a href="/guide/15/Walt-Disney-World/Disneys-Animal-Kingdom">Disney's Animal Kingdom</a></li>
									<li><a href="/guide/395/Walt-Disney-World/Downtown-Disney">Downtown Disney / Disney Springs</a></li>
									<li><a href="http://mousepad.mouseplanet.com/forumdisplay.php?54-Trip-Reports-from-Floridaa">Trip Reports</a></li>
								</ul>
							</li>
							<li><a href="http://mousepad.mouseplanet.com">Forum</a></li>
						</ul>
					</div>
					<!-- </div> -->
				</nav>
			</div>
		</header>		<!-- contain main informative part of the site -->
		<main id="main" role="main">
			<div class="holder padding">
				<div class="ad-holder">
					<!-- wdw_pu_lb -->
<div id='div-gpt-ad-1324422172992-34'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1324422172992-34'); });
</script>
</div>				</div>

				<div class="heading">
										<h1>Walt Disney World Resort Update for March 2-8, 2021</h1>
					
											by <a href="/author/91/Alan_S_Dalinka/" class="name">Alan S. Dalinka</a>, staff writer						<a href="/contact/w/91/Alan-S.-Dalinka" title='Send Alan S. Dalinka an email'><img src="/images/mail.png" height="20"></a>
										<time datetime="2021-03-02">March 2, 2021</time>
				</div>

				<div class="content-holder">
					<div class="ad-block">
						<h6>Advertisement</h6>
						<div class="ad-holder">
							<!-- wdw_pu_cube -->
<div id='div-gpt-ad-1324422172992-33'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1324422172992-33'); });</script>
</div>						</div>
					</div>
					<div class="text-holder">
						<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN" "http://www.w3.org/TR/REC-html40/loose.dtd">
<html><head><meta name="viewport" content="width=device-width, initial-scale=1"><style type="text/css">/* Style Definitions for Enhancements */

h3.Jump {
	background-color: #e6ffe6;
	padding: 10px 1px;
	width: 100%;
	border: none;
	text-align: left;
	outline: none;
	font-size: 20px;
	line-height: 26px;
	box-shadow: 0 8px 6px 0 rgba(0,0,0,0.19), 0 3px 10px 0 rgba(0,0,0,0.19);
}

h4.jumpNews {
	background-color: #d6f2f9;
	padding: 10px 5px;
	width: 100%;
	border: none;
	text-align: left;
	outline: none;
	font-size: 16px;
	line-height: 22px;
	box-shadow: 0 8px 6px 0 rgba(0,0,0,0.19), 0 3px 10px 0 rgba(0,0,0,0.19);
}

h5 {
	background-color: #dec6f7;
	padding: 10px 5px;
	width: 100%;
	border: none;
	text-align: left;
	outline: none;
	font-size: 16px;
	line-height: 22px;
	box-shadow: 0 8px 6px 0 rgba(0,0,0,0.19), 0 3px 10px 0 rgba(0,0,0,0.19);
}

em.NEW {
	font-weight: bold;
	padding: 2px 2px;
	font-style: italic;
	background-color:#00FF00;
	}

h3.HeadBox {
	border:2px solid black; 
	width:99%; 
	background-color: white; 
	padding: 10px 10px; 
	margin-bottom: 12px; 
	font-weight: 900;
}

/* Sliding picture boxes */ 
.PhotoSliderBox { 
	width:98%;  
	overflow:auto;  
	margin:0 auto;  
	background-color: #FAFAD2;  
	border: 1px dotted grey;
}

.SliderLtd { 
	width: 5500px;  
	font-size:12px;  
	white-space: nowrap;  
	max-height:350px;  
	margin-top:10px;  
	margin-left:3px;
}

.picBox{ 
	width:335px; 
	margin-right:5px; 
	margin-left:1px; 
	padding-right:10px; 
	float:left; 
	white-space: normal; 
	text-align: justify;
}

.picBox2{ 
	width:415px; 
	margin-right:5px; 
	margin-left:1px; 
	padding-right:10px; 
	float:left; 
	white-space: normal; 
	text-align: justify;
}

.picBox img{ 
	width:320px; 
	height:240px; 
	border:solid 2px #2d7ac0;
}

.picBox2 img{
    width:400px; 
	height:169px; 
	border:solid 2px #2d7ac0;
}


#picBoxLtd p, #picBoxLtd em{ 
	text-align:justify; 
	font-weight: bold; 
	font-family: Arial, Helvetica, sans-serif; 
	font-size: 100%; 
	font-style:normal;  
	padding:2px;
}
</style><!-- END: Style Definitions --></head><body><h3 class="HeadBox" id="TOPTOP" name="TOPTOP">Walt Disney World Resort Update for March 2 - 8, 2021</h3>

<h3 class="Jump" id="WritersNote" name="WritersNote">&nbsp;Writer's Note, News &amp; Views (Combined)</h3>

<p>Meteorological Spring is underway now that it's March, and here in Central Florida and around Walt Disney World Resort, lots of vibrant blooms are all around. Of course, THE Walt Disney World location for the season is "Fresh EPCOT" which starts this year's Taste of EPCOT International Flower &amp; Garden Festival tomorrow, March 3. I expect to be over at the park a couple of times this week, and I'll share views on our social media channels and in next week's Update.</p>

<p>Since I had not been over to Disney's Animal Kingdom since November, I also made a visit there this past week. As you'll see in the views below, the colors there are quite vibrant too. And, by shear luck, I was there on the day that four-month-old white rhino Ranger made his savana debut on Kilimanjaro Safaris. The not-so-little little guy seemed to capture the attention of all the big cats who are always well physically distanced from both guests and other species on the savana.</p>

<p>This past week, Walt Disney World updated its face coverings policy as it pertains to dining. The general policy statement since the parks began their phased reopening has been that guests (ages 2 and up) must wear face coverings at all times except when eating or drinking while stationary. The updated policy now makes it clear that guests in dining areas must wear their face coverings "while standing, waiting or sitting in dining locations" and that they can only be removed "while actively eating or drinking." For the latest "KNOW BEFORE YOU GO" dining information, visit <a href="https://disneyworld.disney.go.com/experience-updates/dine/">this page of DisneyWorld.com</a>.</p>

<p>Capacity limitations, managed by the Disney Park Pass Reservation system, remain in place. Rumors that the caps have been increased are rampant, and the parks are feeling more crowded, but there have been no official statements on the subject. Park Hopping is available daily in a modified form (only for those with the benefit, only after 2 p.m., and only after you have made and used a Disney Park Pass reservation at another park that day). We are unaware of reports of Park Hopping becoming unavailable due to capacity, but remember, as we head toward Spring Break, that may become something to stay aware of during park visits.</p>

<p>And, as I remind you each week, the Walt Disney World Resort's phased reopening includes enhanced health and safety protocols beyond the capacity restrictions: there are mandatory guest temperature checks, and heightened cleaning especially of high-touch areas, physical distancing, and cast members do enforce the mandatory face coverings requirements. Be sure to check the My Disney Experience or DisneyWorld.com immediately before any planned visit for any last minute changes to phased reopening operations that may impact your visit. Reminder: for those of you who are considering a visit in the near-term or more-distant future, our travel partner <a href="https://www.getawaytoday.com/destination/walt-disney-world-resort?referrerid=5761" target="_blank">Get Away Today</a> can now help you with reservations up to 500 days in advance. More on that <a href="#Discounts">below</a>.</p>

<h4 class="jumpNews">Views of Disney's Animal Kingdom</h4>

<p>I was overdue for a visit to Walt Disney World's newest park. Sure, on Earth Day next month, it will reach its 23rd Anniversary, but at a Resort coming up on it's 50th Anniversary celebration, it's still the new kid. And, speaking of new kids...</p>

<div class="PhotoSliderBox">
<div id="picBoxLtd" style="width:5500px;font-size:12px; white-space: nowrap; max-height:350px; margin-top:10px; margin-left:3px;">
<div class="picBox"><p class="phototour"><a title="Ranger, the now four month old white rhino born at Disney's Animal Kingdom made his debut on the Kilimanjaro Safaris savanna on Tuesday, under the watchful eyes of his mother." rel="lightbox" href="https://www.mouseplanet.info/gallery/d/340270-1/ASD-DAK-02-23-2021+-+12.jpeg"><img width="400" height="300" border="0" alt="" src="https://www.mouseplanet.info/gallery/d/340274-2/ASD-DAK-02-23-2021+-+12.jpeg"></a><br>Ranger, the now four month old white rhino born at Disney's Animal Kingdom made his debut on the Kilimanjaro Safaris savanna on Tuesday, under the watchful eyes of his mother.</p></div>

<div class="picBox"><p class="phototour"><a title="Ranger also captured the attention of the lions during the middle of the afternoon when, ordinarily, they would probably be sleeping." rel="lightbox" href="https://www.mouseplanet.info/gallery/d/340315-1/ASD-DAK-02-23-2021+-+21.jpeg"><img width="400" height="300" border="0" alt="" src="https://www.mouseplanet.info/gallery/d/340319-2/ASD-DAK-02-23-2021+-+21.jpeg"></a><br>Ranger also captured the attention of the lions during the middle of the afternoon when, ordinarily, they would probably be sleeping.</p></div>

<div class="picBox"><p class="phototour"><a title="The black rhino enclosure, on the other hand, is far-removed from where the white rhinos wander." rel="lightbox" href="https://www.mouseplanet.info/gallery/d/340285-1/ASD-DAK-02-23-2021+-+15.jpeg"><img width="400" height="300" border="0" alt="" src="https://www.mouseplanet.info/gallery/d/340289-2/ASD-DAK-02-23-2021+-+15.jpeg"></a><br>The black rhino enclosure, on the other hand, is far-removed from where the white rhinos wander.</p></div>

<div class="picBox"><p class="phototour"><a title="The nile crocodiles appeared to just be sunning themselves as usual." rel="lightbox" href="https://www.mouseplanet.info/gallery/d/340290-1/ASD-DAK-02-23-2021+-+16.jpeg"><img width="400" height="300" border="0" alt="" src="https://www.mouseplanet.info/gallery/d/340294-2/ASD-DAK-02-23-2021+-+16.jpeg"></a><br>The nile crocodiles appeared to just be sunning themselves as usual.</p></div>

<div class="picBox"><p class="phototour"><a title="The young giraffe, now well-acclimated to the savanna, find edible scenery within easy reach." rel="lightbox" href="https://www.mouseplanet.info/gallery/d/340295-1/ASD-DAK-02-23-2021+-+17.jpeg"><img width="400" height="300" border="0" alt="" src="https://www.mouseplanet.info/gallery/d/340299-2/ASD-DAK-02-23-2021+-+17.jpeg"></a><br>The young giraffe, now well-acclimated to the savanna, find edible scenery within easy reach.</p></div>

<div class="picBox"><p class="phototour"><a title="The first elephant scene on a Kilimanjaro Safari ride is usually a solo male." rel="lightbox" href="https://www.mouseplanet.info/gallery/d/340300-1/ASD-DAK-02-23-2021+-+18.jpeg"><img width="400" height="300" border="0" alt="" src="https://www.mouseplanet.info/gallery/d/340304-2/ASD-DAK-02-23-2021+-+18.jpeg"></a><br>The first elephant scene on a Kilimanjaro Safari ride is usually a solo male.</p></div>

<div class="picBox"><p class="phototour"><a title="Flamingo Island is well populated." rel="lightbox" href="https://www.mouseplanet.info/gallery/d/340305-1/ASD-DAK-02-23-2021+-+19.jpeg"><img width="400" height="300" border="0" alt="" src="https://www.mouseplanet.info/gallery/d/340309-2/ASD-DAK-02-23-2021+-+19.jpeg"></a><br>Flamingo Island is well populated.</p></div>

<div class="picBox"><p class="phototour"><a title="Meanwhile, the other big cats on the safari, the cheeta also were quite attentive as Ranger walked within their view." rel="lightbox" href="https://www.mouseplanet.info/gallery/d/340310-1/ASD-DAK-02-23-2021+-+20.jpeg"><img width="400" height="300" border="0" alt="" src="https://www.mouseplanet.info/gallery/d/340314-2/ASD-DAK-02-23-2021+-+20.jpeg"></a><br>Meanwhile, the other big cats on the safari, the cheeta also were quite attentive as Ranger walked within their view.</p></div>

<div class="picBox"><p class="phototour"><a title="The new goat enclosure is themed as a ranger station, overrun with the little ones." rel="lightbox" href="https://www.mouseplanet.info/gallery/d/340320-1/ASD-DAK-02-23-2021+-+22.jpeg"><img width="400" height="300" border="0" alt="" src="https://www.mouseplanet.info/gallery/d/340324-2/ASD-DAK-02-23-2021+-+22.jpeg"></a><br>The new goat enclosure is themed as a ranger station, overrun with the little ones.</p></div>

<div class="picBox"><p class="phototour"><a title="If visiting Disney's Animal Kingdom, be aware that the Kilimanjaro Safaris hours of operation usually differ from the park's hours." rel="lightbox" href="https://www.mouseplanet.info/gallery/d/340280-1/ASD-DAK-02-23-2021+-+14.jpeg"><img width="400" height="300" border="0" alt="" src="https://www.mouseplanet.info/gallery/d/340284-2/ASD-DAK-02-23-2021+-+14.jpeg"></a><br>If visiting Disney's Animal Kingdom, be aware that the Kilimanjaro Safaris hours of operation usually differ from the park's hours.</p></div>
</div>
</div>

<p style="margin-left:1%">Photos by Alan S. Dalinka.</p>

<div class="PhotoSliderBox">
<div id="picBoxLtd" style="width:5500px;font-size:12px; white-space: nowrap; max-height:350px; margin-top:10px; margin-left:3px;">
<div class="picBox"><p class="phototour"><a title="In front of the park (outside its gates), the walk-in photo opportunity now features Kevin, Dug and Russell from 'Up.'" rel="lightbox" href="https://www.mouseplanet.info/gallery/d/340214-1/ASD-DAK-02-23-2021+-+1.jpeg"><img width="400" height="300" border="0" alt="" src="https://www.mouseplanet.info/gallery/d/340218-2/ASD-DAK-02-23-2021+-+1.jpeg"></a><br>In front of the park (outside its gates), the walk-in photo opportunity now features Kevin, Dug and Russell from "Up."</p></div>

<div class="picBox"><p class="phototour"><a title="As spring is underway in Central Florida, the natural trees' colors pop against the Disney-constructed Tree of Life." rel="lightbox" href="https://www.mouseplanet.info/gallery/d/340225-1/ASD-DAK-02-23-2021+-+3.jpeg"><img width="400" height="300" border="0" alt="" src="https://www.mouseplanet.info/gallery/d/340229-2/ASD-DAK-02-23-2021+-+3.jpeg"></a><br>As spring is underway in Central Florida, the natural trees' colors pop against the Disney-constructed Tree of Life.</p></div>

<div class="picBox"><p class="phototour"><a title="Ducks from Donald's Dino Bash make occasional appearances on watercraft around Discovery Island." rel="lightbox" href="https://www.mouseplanet.info/gallery/d/340220-1/ASD-DAK-02-23-2021+-+2.jpeg"><img width="400" height="300" border="0" alt="" src="https://www.mouseplanet.info/gallery/d/340224-2/ASD-DAK-02-23-2021+-+2.jpeg"></a><br>Ducks from Donald's Dino Bash make occasional appearances on watercraft around Discovery Island.</p></div>

<div class="picBox"><p class="phototour"><a title="Chip and Dale in their Dino Bash outfits along with Goofy may appear as well." rel="lightbox" href="https://www.mouseplanet.info/gallery/d/340250-1/ASD-DAK-02-23-2021+-+8.jpeg"><img width="400" height="300" border="0" alt="" src="https://www.mouseplanet.info/gallery/d/340254-2/ASD-DAK-02-23-2021+-+8.jpeg"></a><br>Chip and Dale in their Dino Bash outfits along with Goofy may appear as well.</p></div>

<div class="picBox"><p class="phototour"><a title="Characters from 'The Lion King' also made an appearance during my visit on Tuesday." rel="lightbox" href="https://www.mouseplanet.info/gallery/d/340325-1/ASD-DAK-02-23-2021+-+23.jpeg"><img width="400" height="300" border="0" alt="" src="https://www.mouseplanet.info/gallery/d/340329-2/ASD-DAK-02-23-2021+-+23.jpeg"></a><br>Characters from "The Lion King" also made an appearance during my visit on Tuesday.</p></div>
</div>
</div>

<p style="margin-left:1%">Photos by Alan S. Dalinka.</p>

<div class="PhotoSliderBox">
<div id="picBoxLtd" style="width:5500px;font-size:12px; white-space: nowrap; max-height:350px; margin-top:10px; margin-left:3px;">
<div class="picBox"><p class="phototour"><a title="Proving that the macaws at the park are really free to do what they like, this one decided to spend some time near Harambe Marketplace rather than head to wherever its fellow macaws were performing or hanging out backstage." rel="lightbox" href="https://www.mouseplanet.info/gallery/d/340265-1/ASD-DAK-02-23-2021+-+11.jpeg"><img width="400" height="300" border="0" alt="" src="https://www.mouseplanet.info/gallery/d/340269-2/ASD-DAK-02-23-2021+-+11.jpeg"></a><br>Proving that the macaws at the park are really free to do what they like, this one decided to spend some time near Harambe Marketplace rather than head to wherever its fellow macaws were performing or hanging out backstage.</p></div>

<div class="picBox"><p class="phototour"><a title="A cast member provided treats to one of the tigers (look closely and you'll see the meat treat) at Maharaja Jungle Trek." rel="lightbox" href="https://www.mouseplanet.info/gallery/d/340255-1/ASD-DAK-02-23-2021+-+9.jpeg"><img width="400" height="300" border="0" alt="" src="https://www.mouseplanet.info/gallery/d/340259-2/ASD-DAK-02-23-2021+-+9.jpeg"></a><br>A cast member provided treats to one of the tigers (look closely and you'll see the meat treat) at Maharaja Jungle Trek.</p></div>

<div class="picBox"><p class="phototour"><a title="The aviary at Maharaja Jungle Trek seemed particularly active during my visit." rel="lightbox" href="https://www.mouseplanet.info/gallery/d/340260-1/ASD-DAK-02-23-2021+-+10.jpeg"><img width="400" height="300" border="0" alt="" src="https://www.mouseplanet.info/gallery/d/340264-2/ASD-DAK-02-23-2021+-+10.jpeg"></a><br>The aviary at Maharaja Jungle Trek seemed particularly active during my visit.</p></div>
</div>
</div>

<p style="margin-left:1%">Photos by Alan S. Dalinka.</p>

<p><p class="phototour"><a title="The sun sets behind the floating mountains of Pandora-The World of Avatar. Photo by Alan S. Dalinka." rel="lightbox" href="https://www.mouseplanet.info/gallery/d/340330-1/ASD-DAK-02-23-2021+-+24.jpeg"><img width="400" height="300" border="0" alt="" src="https://www.mouseplanet.info/gallery/d/340334-2/ASD-DAK-02-23-2021+-+24.jpeg"></a><br>The sun sets behind the floating mountains of Pandora-The World of Avatar. Photo by Alan S. Dalinka.</p></p>

<h4 class="jumpNews">Views of EPCOT's "Harmonious" Construction Plus Live Entertainment &amp; Festival Updates</h4>

<p>Harmonious, the next nighttime spectacular being developed for EPCOT, continues to have its new hardware get seen in World Showcase Lagoon. This week, the six-story-tall central ring structure was floated out on to the Lagoon to its permanent location. The ring supports a high-density water curtain, moving lights, fountains and more.</p>

<p>With all the complaints on social media (and even in the comments section on Disney Parks Blog) about changing the sight-lines of World Showcase, folks seem to be forgetting that during the day, the hardware installed for Harmonious will be used for a fountain display in the Lagoon. In other words, we don't yet really know what this is going to look like when activated (so, I am reserving forming an opinion since its just another part of the park under construction right now). At night, it will be part of what Disney says is "one of the largest nighttime spectaculars" Disney Live Entertainment and Walt Disney Imagineering have ever produced. No debut date has been announced, and, indeed, it is possible that the daytime fountain effects could be activated before the nighttime show debuts.</p>

<p class="phototour"><iframe allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen="" frameborder="0" height="315" src="https://www.youtube-nocookie.com/embed/d2qYpyuzSN4" width="560"></iframe><br>
Work continues on the development of Harmonious for EPCOT, but no debut date has been announced. As part of the phased reopening of the Resort, none of the parks have hosted nighttime spectaculars. Video courtesy Disney Parks.</p>

<div class="PhotoSliderBox">
<div id="picBoxLtd" style="width:5500px;font-size:12px; white-space: nowrap; max-height:350px; margin-top:10px; margin-left:3px;">
<div class="picBox"><p class="phototour"><a title="The six-story ring structure is now a prominent part of the World Showcase Lagoon." rel="lightbox" href="https://www.mouseplanet.info/gallery/d/340352-1/Harmonious-D-0227ZP_0394KP-scaled.jpg"><img width="400" height="267" border="0" alt="" src="https://www.mouseplanet.info/gallery/d/340356-2/Harmonious-D-0227ZP_0394KP-scaled.jpg"></a><br>The six-story ring structure is now a prominent part of the World Showcase Lagoon.</p></div>

<div class="picBox"><p class="phototour"><a title="When nighttime spectaculars resume at EPCOT, the ring will be the centerpiece of the new 'Harmonious' show." rel="lightbox" href="https://www.mouseplanet.info/gallery/d/340342-1/Harmonious-B-0227ZP_0322KP-scaled.jpg"><img width="400" height="253" border="0" alt="" src="https://www.mouseplanet.info/gallery/d/340346-2/Harmonious-B-0227ZP_0322KP-scaled.jpg"></a><br>When nighttime spectaculars resume at EPCOT, the ring will be the centerpiece of the new "Harmonious" show.</p></div>

<div class="picBox"><p class="phototour"><a title="Other pieces of hardware for Harmonious are also quite large and will remain permanently in World Showcase Lagoon. It is not yet clear what the 'fountain' that these pieces will create by day will look like." rel="lightbox" href="https://www.mouseplanet.info/gallery/d/340347-1/Harmonious-C-0227ZP_0347KP-scaled.jpg"><img width="400" height="262" border="0" alt="" src="https://www.mouseplanet.info/gallery/d/340351-2/Harmonious-C-0227ZP_0347KP-scaled.jpg"></a><br>Other pieces of hardware for Harmonious are also quite large and will remain permanently in World Showcase Lagoon. It is not yet clear what the "fountain" that these pieces will create by day will look like.</p></div>
</div>
</div>

<p style="margin-left:1%">Photos Courtesy Disney Parks.</p>

<p>EPCOT will feature more live entertainment during the Taste of EPCOT International Flower &amp; Garden Festival &mdash; March 3 to July 5, 2021. The updated entertainment offerings listed on <a href="https://disneyworld.disney.go.com/entertainment/epcot/new-epcot-entertainment/" target="_blank">EPCOT's entertainment page of DisneyWorld.com</a> are below (check Times Guide and signs for showtimes):</p>

<p><strong>Jammin' Gardeners (Canada Mill Stage)</strong><br>
Tap your feet to the syncopated sounds of the funkiest gardeners around.</p>

<p><strong>Voices of Liberty (America Gardens Theatre)</strong><br>
Get swept away by inspiring vocal performances celebrating America&rsquo;s spirit and beauty.</p>

<p><strong>Mariachi Cobre (America Gardens Theatre)</strong><br>
Enjoy an exuberant performance of world-famous, traditional folk music.</p>

<p><strong>Pianist (World Showplace)</strong><br>
Relax and enjoy a selection of songs of the season.</p>

<p><em class="NEW">NEW</em> <strong>City Beautiful Bandstand (America Gardens Theatre)</strong><br>
Watch bands from Orlando&mdash; known as "The City Beautiful"&mdash;perform the songs of yesterday and today. Performances are on Sunday, Monday, Friday and Saturday only.</p>

<ul><li><strong>EPIC! - (Pop)</strong>&mdash; March 5 to 8, April 16 to 19, &amp; May 28 to 31<br>
	Get ready for a true multi-generational "SuperBand" who continues their run of success&mdash;making appearances all over the world with their Concert Style high-energy show!</li>
	<li><strong>Motown in Motion (Motown / R&amp;B)</strong>&mdash; March 19 to 22, April 30 to May 3, &amp; June 11 to 14<br>
	Get moving to the sounds of this power-packed, live Motown musical tribute to some of the greatest American artists of all time.</li>
	<li><strong>Vintage Vinyl Band (Vintage Pop)</strong>&mdash; March 12 to 15, April 23 to 26, &amp; June 4 to 7<br>
	Drop in for a spin with this unconventional top 40 cover band that specializes in retrofitting today's hits into yesterday's sound, while weaving in classics from the American Songbook.</li>
	<li><strong>The Hooligans (Pop)</strong>&mdash; March 26 to 29, May 7 to 10, &amp; June 18 to 21<br>
	Rock the night away to classic tunes ranging from the British Invasion to &lsquo;80s pop to &lsquo;90s alternative.</li>
	<li><strong>The Spazmatics (&lsquo;80s Pop)</strong>&mdash; April 2 to 5, May 14 to 17, &amp; June 25 to 28<br>
	Go wild for this band that recaptures all the best of the &lsquo;80s. Outstanding musicianship combined with creative flair and styles make for an evening of pure energy and entertainment.</li>
	<li><strong>Latin Ambition (Latin/Pop)</strong>&mdash; April 9 to 12, May 21 to 24, &amp; July 2 to 5<br>
	Discover why this bilingual Latin American Party Band has received accolades and honors industry-wide for over a decade&mdash;and earning their reputation by promising energy, showmanship and diversity.</li>
</ul><p>And <a href="https://disneyparks.disney.go.com/blog/2021/02/foodie-guide-to-2021-taste-of-epcot-international-flower-garden-festival-opening-mar-3/" target="_blank">Disney Parks Blog</a> has published its Foodie Guide to the Taste of EPCOT International Flower &amp; Garden Festival too.</p>

<h4 class="jumpNews">Disney Parks Celebrates Women's History Month Including Special Offerings at Disney Springs</h4>

<p><a href="https://disneyparks.disney.go.com/blog/2021/03/celebrating-womenshistorymonth-iconic-women-behind-disney-parks/" target="_blank">Disney Parks Blog</a> started Disney Parks' celebration of Women's History Month by honoring several of the women who were instrumental "trailblazers who shaped the theme park industry and paved the way for the women and girls who followed in their footsteps" at Walt Disney Imagineering. The tributes run from Mary Blair (probably best known for her work on it's a small world), to Harriet Burns (the first woman hired by what is now Imagineering), Alice Davis, Dorothea Redmond, Doris Woodward, and Kathy Mangum. There will be a special feature published by Disney Parks Blog on March 8, International Women's Day.</p>

<div>
<center>
<blockquote class="twitter-tweet">
<p dir="ltr" lang="en">Recognize that artwork?&#8239;For&#8239;Women&rsquo;s History Month,&#8239;we&rsquo;re celebrating the achievements of the <a href="https://twitter.com/hashtag/WomenBehindtheMagic?src=hash&amp;ref_src=twsrc%5Etfw">#WomenBehindtheMagic</a>. Learn more about these iconic women of Disney: <a href="https://t.co/AKjO29bPpH">https://t.co/AKjO29bPpH</a> <a href="https://t.co/B5YRAdveHs">pic.twitter.com/B5YRAdveHs</a></p>
&mdash; Disney Parks (@DisneyParks) <a href="https://twitter.com/DisneyParks/status/1366464678889721856?ref_src=twsrc%5Etfw">March 1, 2021</a></blockquote>
<script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></center>
</div>

<p>Disney Springs will celebrate the contributions of women by "spotlighting the talented women who showcase their super powers as entrepreneurs, to the business-savvy role models and artists behind-the-scenes," according to <a href="https://disneyparks.disney.go.com/blog/2021/03/celebrate-her-story-at-disney-springs-in-honor-of-womens-history-month/" target="_blank">Disney Parks Blog</a>. The "Celebrate HER Story at Disney Springs" will include special "treats" created by women, female-led entertainment, and other unique offerings. The Art of Disney and WonderGround Gallery will focus, on a rotating basis, on female filmmakers, artists, and directors who have been a part of Walt Disney Animation Studios. Visiting artists will appear on select dates at both locations. Fabiola Garza Villalobos (who created the pattern on the newest Dooney &amp; Bourke collection featuring favorite characters from "Robinhood") will appear on March 8 at 10 a.m. until noon at Ever After Jewelry Co. &amp; Accessories and will sign purchases. New entertainment will appear on the Waterside Stage on Wednesday nights from 5-9 p.m., including Just Imagin3 and Skillzmatic Band "SMB". Specialty food and beverage offerings and merchandise will be featured as well.</p>

<div>
<center>
<blockquote class="twitter-tweet">
<p dir="ltr" lang="en">"Celebrate HER Story" at <a href="https://twitter.com/DisneySprings?ref_src=twsrc%5Etfw">@DisneySprings</a> as we spotlight women in artistry, special treats created by women, talented female-led entertainment, unique offerings, and more in honor of <a href="https://twitter.com/hashtag/WomensHistoryMonth?src=hash&amp;ref_src=twsrc%5Etfw">#WomensHistoryMonth</a>! &#10024; Full details here: <a href="https://t.co/UIjA0E19pQ">https://t.co/UIjA0E19pQ</a> <a href="https://twitter.com/hashtag/CelebrateHerStory?src=hash&amp;ref_src=twsrc%5Etfw">#CelebrateHerStory</a> <a href="https://t.co/5SC5zBJLes">pic.twitter.com/5SC5zBJLes</a></p>
&mdash; Disney Parks (@DisneyParks) <a href="https://twitter.com/DisneyParks/status/1366510037821255682?ref_src=twsrc%5Etfw">March 1, 2021</a></blockquote>
<script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></center>
</div>

<h4 class="jumpNews">Reminder: 2021 Florida Resident Discover Disney Tickets Now Available</h4>

<p>As the year began, Disney launched its 2021 Florida Resident Discover Disney Ticket. The $199 plus tax ticket provides four days of park visits. The ticket can be used on consecutive or non-consecutive days through June 18, 2021 (but not at all on March 26-April 11, or May 28-31). The Park Hopper option can be added for $42.50/ticket plus tax.</p>

<p>There is also a 3-Day version (with same blockout dates) available for $179 plus tax (add $42.50/ticket plus tax for Park Hopper).</p>

<p>A 2-Day version is available to purchase and use only through March 11 for $149/tax (add $37.50/ticket plus tax for Park Hopper).</p>

<p>Like other ticket types, guests must also separately make Disney Park Pass reservations for a specific park each date they wish to use a Discover Disney Ticket (and, for Park Hopper, must visit that reserved park and may only Hop when that day's window opens subject to capacity).</p>

<h4 class="jumpNews" id="thisthat" name="thisthat">This &amp; That&hellip;</h4>

<p>&hellip;Last week, we noted that <a href="https://disneyparks.disney.go.com/blog/2021/02/disney-parks-best-bites-february-2021/" target="_blank">Disney Parks Blog</a> published its list of February 2021 Best Bites, highlighting the new food items at Disney's Animal Kingdom inspired by the upcoming film <em>Raya and the Last Dragon</em>, the March 22 return of breakfast at Hollywood &amp; Vine at Disney's Hollywood Studios (with character waving photo opportunities), new menu items at Tony's Town Square Restaurant and Sunshine Tree Terrace at Magic Kingdom, the return of "Sangria University" at Three Bridges Bar &amp; Grill at Disney's Coronado Springs Resort (plus a couple of new offerings at the resort's Dahlia Lounge), and new offerings at Disney Springs.</p>

<p><p class="phototour"><a title="The sand sculpture honoring the upcoming debut of the film 'Raya and The Last Dragon' is located on Discovery Island at Disney's Animal Kingdom and it should remain on display through the middle of the month. Photo by Alan S. Dalinka." rel="lightbox" href="https://www.mouseplanet.info/gallery/d/340230-1/ASD-DAK-02-23-2021+-+4.jpeg"><img width="400" height="300" border="0" alt="" src="https://www.mouseplanet.info/gallery/d/340234-2/ASD-DAK-02-23-2021+-+4.jpeg"></a><br>The sand sculpture honoring the upcoming debut of the film "Raya and The Last Dragon" is located on Discovery Island at Disney's Animal Kingdom and it should remain on display through the middle of the month. Photo by Alan S. Dalinka.</p></p>

<p><p class="phototour"><a title="Seasonal limited time food and beverage offerings at Disney's Animal Kingdom are also joined by special limited time 'Raya' themed offerings. Photo by Alan S. Dalinka." rel="lightbox" href="https://www.mouseplanet.info/gallery/d/340235-1/ASD-DAK-02-23-2021+-+5.jpeg"><img width="400" height="300" border="0" alt="" src="https://www.mouseplanet.info/gallery/d/340239-2/ASD-DAK-02-23-2021+-+5.jpeg"></a><br>Seasonal limited time food and beverage offerings at Disney's Animal Kingdom are also joined by special limited time "Raya" themed offerings. Photo by Alan S. Dalinka.</p></p>

<p>&hellip;Reminder: Passholders can save 30% on select merchandise at all Walt Disney World owned-and-operated locations through today, March 2, 2021.</p>

<p>&hellip;Speaking of Passholders, the <a href="https://disneyworld.disney.go.com/passholder-program/specials/" target="_blank">Passholder Extras page of DisneyWorld.com</a> lists a few extra weekday-only perks for Passholders available now in DinoLand USA at Disney's Animal Kingdom through March 19, 2021 (valid annual pass card and photo ID required):</p>

<ul><li>Passholders that purchase 3 game tickets at Chester &amp; Hester's Dinosaur Treasurers for Fossil Fun Games will receive a complimentary retired, non-Disney plus consolation prize (operates one hour after park opening until 4 p.m.)</li>
	<li>Restaurantosaurus Lounge features 4 exclusive beverages available for purchase: Tyrannosaurus Wreck, Fossil Fuel, Pterodactyl Punch and Triceraberry Pop (open 10:30 a.m. until park close)</li>
	<li>Dino-Bite Snacks offers an exclusive Donald Duck cookie for purchase (10:30 a.m. until park close)</li>
	<li>The complimentary Donald Duck magnet, which started to be distributed back when last year's EPCOT International Flower &amp; Garden Festival began but got cut short by more than a month when the parks temporarily closed in mid-March, is again available to Passholders from Park Open until 4 p.m. on Mondays through Fridays.</li>
</ul><p><p class="phototour"><a title="Donald Duck with Spike the Bee Passholder magnet is available in DinoLand U.S.A. on weekdays until 4 p.m. Photo by Alan S. Dalinka." rel="lightbox" href="https://www.mouseplanet.info/gallery/d/340245-1/ASD-DAK-02-23-2021+-+7.jpeg"><img width="400" height="300" border="0" alt="" src="https://www.mouseplanet.info/gallery/d/340249-2/ASD-DAK-02-23-2021+-+7.jpeg"></a><br>Donald Duck with Spike the Bee Passholder magnet is available in DinoLand U.S.A. on weekdays until 4 p.m. Photo by Alan S. Dalinka.</p></p>

<p><p class="phototour"><a title="To find magnet distribution, follow the cast members with Passholder signs past the posted signs (have your photo ID handy). Photo by Alan S. Dalinka." rel="lightbox" href="https://www.mouseplanet.info/gallery/d/340240-1/ASD-DAK-02-23-2021+-+6.jpeg"><img width="400" height="300" border="0" alt="" src="https://www.mouseplanet.info/gallery/d/340244-2/ASD-DAK-02-23-2021+-+6.jpeg"></a><br>To find magnet distribution, follow the cast members with Passholder signs past the posted signs (have your photo ID handy). Photo by Alan S. Dalinka.</p></p>

<p>&hellip;Walt Disney World Golf is offering a series of four weekly Junior Golf Camps in March. More information is available on the official <a href="https://www.golfwdw.com/blog/317-walt-disney-world-golf-is-offering-a-series-of-four-weekly-junior-golf-camps-in-march?utm_source=newsletter_639&amp;utm_medium=email&amp;utm_campaign=walt-disney-world-golf-is-offering-a-series-of-four-weekly-junior-golf-camps-in-march" target="_blank">Walt Disney World Golf Blog</a>.</p>

<p>&hellip;Reminder: Raglan Road at Disney Springs will host its annual St. Patrick's Day celebration as "a festival like no other." The Mighty St. Patrick&rsquo;s Festival &ndash; Unplugged! will run March 12-17, 2021. Reservations are available at <a href="http://raglanroad.com" target="_blank">RaglanRoad.com</a> or call (407)938-0300.</p>

<blockquote>
<p>Think more acoustic than electric. More intimate than boisterous. The same great live entertainment, with all bands imported from Ireland. The same delicious Irish food and drink. It's the most authentic Irish celebration in America, and it's putting safety first for guests with a reservation-only event.</p>

<p>"Everyone can enjoy the usual lively happenings and practiced hospitality, which includes gift competitions and loads of giveaways," says pub co-owner John Cooke. "And it remains the best Irish hospitality experience in America."</p>

<p>On St. Patrick's Day, March 17, Raglan Road will open at 10 a.m. with a $10 cover charge for guests. Reservations are strongly recommended due to limited space. Guests can book a two-hour slot to join the Raglan Road Irish Pub festivities at Disney Springs, with numbers strictly managed to guarantee social distancing is respected. This year, gathering around bars or stages will not be permitted. The pub requests that guests respect their two-hour booking to ensure that as many of Raglan Road's loyal fans have the chance to enjoy America's finest St. Patrick&rsquo;s festival.</p>

<p>Raglan Road guests can sip from a huge range of Irish whiskeys, local craft beers and hand-crafted cocktails while choosing from the chef&rsquo;s selection of authentic Irish dishes, including fresh-caught fish with chips. Those authentic fish &amp; chips also are available to go at the adjacent Cooke's of Dublin counter.</p>

<p>The Mighty Festival &ndash; Unplugged! entertainment lineup will begin with the Raglan Road Irish Dancers, plucked from the casts and stages of the world&rsquo;s greatest Irish dance shows. This troupe of extraordinary dancers will perform throughout the festival.</p>
</blockquote>

<p>&hellip;And while at Disney Springs, Disney Channel is promoting "Disney Secrets of Sulphur Springs" with an interactive poster on the exterior wall of Disney Days of Christmas (facing Art of Disney store). Just scan the scan the QR code when visiting the display "to watch the mystery unfold!" The first five episodes of the show are available for streaming on Disney+.</p>

<div>
<center>
<blockquote class="twitter-tweet">
<p dir="ltr" lang="en">Disney&rsquo;s <a href="https://twitter.com/hashtag/SecretsofSulphurSprings?src=hash&amp;ref_src=twsrc%5Etfw">#SecretsofSulphurSprings</a> made it to <a href="https://twitter.com/DisneySprings?ref_src=twsrc%5Etfw">@DisneySprings</a> for a mysterious photo op! Check out more of <a href="https://twitter.com/Preston_Oliver?ref_src=twsrc%5Etfw">@preston_oliver</a> and <a href="https://twitter.com/KylieghCurran?ref_src=twsrc%5Etfw">@kylieghcurran</a>&rsquo;s <a href="https://twitter.com/WaltDisneyWorld?ref_src=twsrc%5Etfw">@WaltDisneyWorld</a> adventures here: <a href="https://t.co/aDXqPK8D01">https://t.co/aDXqPK8D01</a> <a href="https://t.co/RMrUQLyt5V">pic.twitter.com/RMrUQLyt5V</a></p>
&mdash; Disney Parks (@DisneyParks) <a href="https://twitter.com/DisneyParks/status/1365708533866577922?ref_src=twsrc%5Etfw">February 27, 2021</a></blockquote>
<script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></center>
</div>

<p>&hellip;And, in the Marketplace, the DVC kiosk has been refreshed with a model of Disney's Riviera Resort built out of LEGO bricks.</p>

<div>
<center>
<blockquote class="twitter-tweet">
<p dir="ltr" lang="en">The <a href="https://twitter.com/LEGO_Group?ref_src=twsrc%5Etfw">@LEGO_GROUP</a> model of Disney&rsquo;s Riviera Resort is now on display at the Disney Vacation Club kiosk at <a href="https://twitter.com/DisneySprings?ref_src=twsrc%5Etfw">@DisneySprings</a> Marketplace. Be sure to check it out on your next visit! <a href="https://t.co/3kYSybsdGM">pic.twitter.com/3kYSybsdGM</a></p>
&mdash; Disney Parks (@DisneyParks) <a href="https://twitter.com/DisneyParks/status/1364999261931249676?ref_src=twsrc%5Etfw">February 25, 2021</a></blockquote>
<script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></center>
</div>

<p>&hellip;Just beyond Disney Springs in Lake Buena Vista, Portillo's Orlando now plans to open its doors on March 23. Stay tuned for those Chicago-style Hot Dogs, Italian Beef Sandwiches, Chocolate cake and more.</p>

<p>&hellip;In downtown Orlando, Dr. Phillips Center for the Performing Arts "Frontyard Festival" will feature "The Music of Disney on Broadway" with Michael James Scott, Ashley Brown, Kissy Simmons and Josh Strickland, all of whom performed at past editions of the Disney on Broadway Concert Series at EPCOT International Festival of the Arts. Those concerts were not held this year as part of the "Taste of" Festival, but the performers will sing Disney favorites on March 20 at 1:30 p.m. and 8 p.m., and on March 21 at 8 p.m. Tickets for these outdoor, physically distanced concerts, start at $25 at <a href="http://drphillipscenter.org">drphillipscenter.org</a>.</p>

<h3 class="Jump" id="Newsletter" name="Newsletter">Subscribe to Our Newsletter</h3>

<p>The MousePlanet Newsletter is here! The newsletter contains a recap of the week's articles (in case you miss a day), news that may have developed since the weekly Updates were published, and tips about what's happening at the Disney theme parks for the coming weekend. We'll also include a fun bonus, such as an Eye Spy or a trivia question. To subscribe to our free newsletter, just enter your email in the box below.</p>
<!-- BEGIN: Constant Contact Bubble Opt-in Email List Form -->

<div align="center">
<table border="0" cellpadding="0" cellspacing="0" width="350"><tbody><tr bgcolor="#006699" valign="top"><td rowspan="2" width="9"><img border="0" height="9" src="https://imgssl.constantcontact.com/ui/images/visitor/tl_brdr2_trans.gif" width="9"></td>
			<td bgcolor="#006699" height="1" width="250"><img border="0" height="1" src="https://imgssl.constantcontact.com/ui/images/spacer.gif" width="1"></td>
			<td align="right" rowspan="2" width="9"><img border="0" height="9" src="https://imgssl.constantcontact.com/ui/images/visitor/tr_brdr2_trans.gif" width="9"></td>
		</tr><tr><td bgcolor="#ffffff" height="8" width="250"><img border="0" height="1" src="https://imgssl.constantcontact.com/ui/images/spacer.gif" width="1"></td>
		</tr><tr><td colspan="3" style="border-right-color: #006699; border-left-color: #006699; border-right-width: 1px; border-left-width: 1px; border-right-style: solid; border-left-style: solid;" width="250">
			<div align="center">
			<form action="http://visitor.r20.constantcontact.com/d.jsp" method="post" name="ccoptin" style="margin-bottom: 3px;" target="_blank"><span style="color: #006699; font-family: Arial; font-size: 18px; font-weight: bold;">Join the MousePlanet Newsletter</span><br><span style="color: #000000; font-family: Arial; font-size: 10px; font-weight: normal;">Email:</span> <input name="ea" size="50" style="border: 1px solid #999999; font-family: Arial; font-size: 10px;" type="text"><input class="submit" name="go" style="font-family: Arial,Helvetica,sans-serif; font-size: 11px;" type="submit" value="Join"><input name="llr" type="hidden" value="5xlnz5eab"><input name="m" type="hidden" value="1104839880446"><input name="p" type="hidden" value="oi"></form>
			</div>
			</td>
		</tr><tr bgcolor="#006699" valign="bottom"><td rowspan="2"><img border="0" height="9" src="https://imgssl.constantcontact.com/ui/images/visitor/bl_brdr2_trans.gif" width="9"></td>
			<td bgcolor="#ffffff" height="8" width="250"><img border="0" height="1" src="https://imgssl.constantcontact.com/ui/images/spacer.gif" width="1"></td>
			<td align="right" rowspan="2"><img border="0" height="9" src="https://imgssl.constantcontact.com/ui/images/visitor/br_brdr2_trans.gif" width="9"></td>
		</tr><tr><td bgcolor="#006699" width="250"><img border="0" height="1" src="https://imgssl.constantcontact.com/ui/images/spacer.gif" width="1"></td>
		</tr></tbody></table></div>
<!-- END: Constant Contact Bubble Opt-in Email List Form --><!-- BEGIN: SafeSubscribe -->

<div align="center" style="padding-top: 5px;"><img alt="" border="0" height="14" src="https://imgssl.constantcontact.com/ui/images1/safe_subscribe_logo.gif" width="200"></div>
<!-- END: SafeSubscribe -->

<h3 class="Jump" id="Networks" name="Networks">Join Our Networks</h3>

<div class="social-media-row">
<h3 style="text-align: center;">Follow @MousePlanet on...</h3>

<div style="text-align: center;"><a class="social-icon" href="http://instagram.com/mouseplanet" id="instagram-icon" style="display: inline-block; width: 64px; height: 64px; margin: 10px; background-color: #3f729b;" title="MousePlanet on Instagram"><img alt="Instagram Logo" src="http://mouseplanet.com/social_icons/instagram-64.png"></a> <a class="social-icon" href="https://twitter.com/MousePlanet" id="twitter-icon" style="display: inline-block; width: 64px; height: 64px; margin: 10px; background-color: #00aced;" title="MousePlanet on Twitter"> <img alt="Twitter Logo" src="http://mouseplanet.com/social_icons/twitter-64.png"></a></div>
</div>

<h3 style="text-align: center;">Follow MousePlanet on Facebook:</h3>

<div style="text-align: center;"><iframe frameborder="0" height="214" scrolling="no" src="https://www.facebook.com/plugins/page.php?href=https%3A%2F%2Fwww.facebook.com%2Fmouseplanet%2F&amp;tabs&amp;width=340&amp;height=214&amp;small_header=false&amp;adapt_container_width=true&amp;hide_cover=false&amp;show_facepile=true&amp;appId" style="border: none; overflow: hidden;" width="340"></iframe></div>

<h3 class="Jump" id="Discounts" name="Discounts">Resorts Availability, Ticket Advice &amp; Special Offers</h3>

<p><em>Note: MousePlanet does not edit past Updates to reflect price increases; for up-to-date prices, check the most recent Walt Disney World Resort Update.</em></p>

<p>Walt Disney World Resort Vacation Packages can now be booked up to 500 days in advance on a rolling calendar. That's right, you can now book packages for travel through early July 2022, and a package can be held for just a $200 downpayment with final payment due 30 days prior to travel.</p>

<p>Our travel partner <a href="https://www.getawaytoday.com/destination/walt-disney-world-resort?referrerid=5761" target="_blank">Get Away Today</a> is available to help you book rooms and packages, and include its complimentary Concierge Services. Get Away Today <a href="https://www.getawaytoday.com/two-extra-days-2021?referrerid=5761" target="_blank">can also assist you</a> with the new Walt Disney World Resort offer that became available back in January: two free theme park days when you purchase at least a 4-night Disney Hotel stay and 3-Day Walt Disney World Resort tickets (the new offer is valid for vacation packages for travel through September 25, 2021, and does not apply to ticket-only orders). For all theme park ticket holders (day guests, resort guests, and Annual Passholders), though, for the foreseeable future, all guests are required to use the Disney Parks Pass System to reserve dates for guest park visits in addition to having a valid admission.</p>

<p class="phototour"><a href="https://www.getawaytoday.com/two-extra-days-2021?referrerid=5761" target="_blank"><img alt="Get Away Today can help you book Disney's latest promotional offers" src="https://www.mouseplanet.info/gallery/d/338744-2/2-Days-Free-WDW-Large.jpg" style="width: 540px; height: 389px;"></a></p>

<p>Get Away Today can also help you book other discounted Disney hotel stays for travel in 2021, including the continuing 35% discount on Disney Hotels for travel through April 17, 2021, which may be the better option for some guests traveling this spring. With Get Away Today's complimentary Price Monitoring, any time a special comes out, it will automatically price check it for each of its guests. If the new special is better, it will automatically apply the new savings and let the guest know. If it's not a better deal, they will leave everything as is, and keep their eyes peeled for future promotions that could save guests more.</p>

<p>Now through April 30, you can even cancel a reservation up to 24 hours before check0in for free.</p>

<p>You can get a vacation quote from Get Away Today <a href="https://bit.ly/mpgetaway" target="_blank">here</a>. (Responses provided in 1 to 3 business days.) You can also call 855-GET-AWAY during regular business hours (Monday - Friday 9am-5pm MT) and tell them MousePlanet sent you!</p>

<p class="phototour"><a href="https://www.getawaytoday.com/destination/walt-disney-world-resort?referrerid=5761" target="_blank"><img alt="Get Away Today Logo" src="https://www.mouseplanet.info/gallery/d/285821-2/GAT+Logo+New.jpg" style="max-width: 400px; width: 300px; height: 120px;"></a></p>

<p>Only purchase Disney theme park tickets directly from Disney, an authorized seller, or a travel agency like MousePlanet travel partner <strong><a href="https://www.getawaytoday.com/destination/walt-disney-world-resort?referrerid=5761" target="_blank">Get Away Today</a>!</strong>.As always, we remind our readers that Walt Disney World Resort theme park tickets are rarely offered at deep discounts unless you are a resident of Florida or eligible for U.S. Military Personnel benefits. Historically, non-Florida residents tend to benefit the most by purchasing tickets in advance (and, of course, being mindful of the rules relevant to those tickets). <strong>Don't get scammed!</strong> Never buy tickets from an unofficial or secondary outlet, such as through eBay or Craigslist. Never rent or purchase tickets from people approaching you outside Disney property stating they have remaining days or leftover tickets. This practice is against the terms of use for Walt Disney World Theme Park admissions, and may result in denial of entry. There is no way to determine if these tickets are valid until you try to use them to enter the parks.</p>

<p>Be sure to check out Get Away Today's Universal Orlando Resort <a href="https://www.getawaytoday.com/destination/universal-orlando-resort?referrerid=5761" target="_blank">ticket offers</a> too.</p>
<p>&nbsp</p>
					<p>
						<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
						<ins class="adsbygoogle"
						     style="display:block"
						     data-ad-format="autorelaxed"
						     data-ad-client="ca-pub-8218384467922636"
						     data-ad-slot="7483507399"></ins>
						<script>
						     (adsbygoogle = window.adsbygoogle || []).push({});
						</script>

					</p>

					</div>
				<div class="social-block">
					<div class="info-share">
						<h4>Share this article</h4>
							<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-514bcc3157fb0a34" async="async"></script>
							<div class="addthis_sharing_toolbox"></div>
					</div>
					<div class="info-tag">
						<h4>Tags</h4>
						<ul class="list-tags">
							<li><a href="/tag/101/Walt_Disney_World_Resort_Update/">Walt Disney World Resort Update</a></li><li><a href="/tag/1097/Disney_Springs/">Disney Springs</a></li><li><a href="/tag/104/Disneys_Animal_Kingdom/">Disneys Animal Kingdom</a></li><li><a href="/tag/103/Epcot/">Epcot</a></li><li><a href="/tag/1045/Refurbishments_And_Closures/">Refurbishments And Closures</a></li>						</ul>
					</div>
				</div>

				<article class="article-info">
					<h4>Similar Articles</h4>
					<ul class="list-articles">

							<li>	<a href="/12873/Walt_Disney_World_Resort_Update_for_February_23__March_1_2021" class="img-holder">	<img src=" https://www.mouseplanet.info/gallery/d/340112-2/Mickey-Minnie-50th.jpg" alt="Walt Disney World Resort Update for February 23 - March 1, 2021" width="261" height="193"></a>	<a href="/12873/Walt_Disney_World_Resort_Update_for_February_23__March_1_2021" class="title">Walt Disney World Resort Update for February 23 - March 1, 2021</a>	<br /><span class="author">by <a href="/12873/Walt_Disney_World_Resort_Update_for_February_23__March_1_2021" class="name">Alan S. Dalinka</a> <time datetime="2021-02-23">February 23, 2021</time></span>  </li><li>	<a href="/12869/Walt_Disney_World_Resort_Update_for_February_1722_2021" class="img-holder">	<img src=" https://www.mouseplanet.info/gallery/d/339944-2/ASD-02-10-2021-EP-Legacy+-+3.jpeg" alt="Walt Disney World Resort Update for February 17-22, 2021" width="261" height="193"></a>	<a href="/12869/Walt_Disney_World_Resort_Update_for_February_1722_2021" class="title">Walt Disney World Resort Update for February 17-22, 2021</a>	<br /><span class="author">by <a href="/12869/Walt_Disney_World_Resort_Update_for_February_1722_2021" class="name">Alan S. Dalinka</a> <time datetime="2021-02-17">February 17, 2021</time></span>  </li><li>	<a href="/12863/Walt_Disney_World_Resort_Update_for_February_915_2021" class="img-holder">	<img src=" https://www.mouseplanet.info/gallery/d/339604-2/ASD-DS-Amorettes-02-04-21+-+4.jpeg" alt="Walt Disney World Resort Update for February 9-15, 2021" width="261" height="193"></a>	<a href="/12863/Walt_Disney_World_Resort_Update_for_February_915_2021" class="title">Walt Disney World Resort Update for February 9-15, 2021</a>	<br /><span class="author">by <a href="/12863/Walt_Disney_World_Resort_Update_for_February_915_2021" class="name">Alan S. Dalinka</a> <time datetime="2021-02-09">February 9, 2021</time></span>  </li>


					</ul>					
				</article>
			</div>

			<div class="comment-block">
				<div class="holder">
					<h2>Comments</h2>
					<ol class="list-comments">

						<li><strong class="comment-info"><a href="https://mousepad.mouseplanet.com/showthread.php?t=309626" target="_blank">Discuss this article on MousePad.</a></strong>						
					</ol>
				</div>
			</div>
			<div class="ad-holder has-margin">
					<!-- ros_footer -->
<div id='div-gpt-ad-1324422172992-25' >
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1324422172992-25'); });
</script>
</div>			</div>
		</main>
		<footer id="footer">
			<div class="footer-area">
				<div class="holder">
					<article class="col-left">
						<h2>About MousePlanet</h2>
						<p>MousePlanet is your independent consumer guide to Disney travel and vacations, covering Disneyland, Walt Disney World and the Disney Cruise Line. Look to MousePlanet for daily news, weekly theme park updates, and detailed travel and resort guides for your favorite Disney destinations. As with any endeavor of this size and complexity, we couldn't hope to succeed without the assistance of our readers. We encourage you to submit news, updates and feedback from your Disney travels.</p>
					</article>
					<article class="col-right">
						<h2>Join Our Newsletter</h2>
						<p>Subscribe to our weekly newsletter for all the latest updates.</p>


							<div class="ctct-embed-signup" style="font: 16px Helvetica Neue, Arial, sans-serif; font: 1rem Helvetica Neue, Arial, sans-serif; line-height: 1.5; -webkit-font-smoothing: antialiased;">
							   <div style="color:#5b5b5b; background-color:#146cba; border-radius:5px;">
							       <span id="success_message" style="display:none;">
							           <div style="text-align:center;"><h3>Thanks for signing up!</h3></div>
							       </span>
							       <form data-id="embedded_signup:form" class="ctct-custom-form Form" name="embedded_signup" method="POST" action="https://visitor2.constantcontact.com/api/signup">
							           <p></p>
							           <div class="email-form">
							           <!-- The following code must be included to ensure your sign-up form works properly. -->
							           <input data-id="ca:input" name="ca" value="37989a29-c267-4e1d-b2a8-6939f994d994" type="hidden">
							           <input data-id="list:input" name="list" value="1" type="hidden">
							           <input data-id="source:input" name="source" value="EFD" type="hidden">
							           <input data-id="required:input" name="required" value="list,email" type="hidden">
							           <input data-id="url:input" name="url" value="" type="hidden">
							           <p data-id="Email Address:p" > <input data-id="Email Address:input" name="email" value="" placeholder="Email Address" maxlength="80" type="text">
							           <input type="submit"  data-enabled="enabled" value="Go">
							           </div>
							       </form>
							   </div>
							</div>
							<script type='text/javascript'>
							   var localizedErrMap = {};
							   localizedErrMap['required'] = 		'This field is required.';
							   localizedErrMap['ca'] = 			'An unexpected error occurred while attempting to send email.';
							   localizedErrMap['email'] = 			'Please enter your email address in name@email.com format.';
							   localizedErrMap['birthday'] = 		'Please enter birthday in MM/DD format.';
							   localizedErrMap['anniversary'] = 	'Please enter anniversary in MM/DD/YYYY format.';
							   localizedErrMap['custom_date'] = 	'Please enter this date in MM/DD/YYYY format.';
							   localizedErrMap['list'] = 			'Please select at least one email list.';
							   localizedErrMap['generic'] = 		'This field is invalid.';
							   localizedErrMap['shared'] = 		'Sorry, we could not complete your sign-up. Please contact us to resolve this.';
							   localizedErrMap['state_mismatch'] = 'Mismatched State/Province and Country.';
								localizedErrMap['state_province'] = 'Select a state/province';
							   localizedErrMap['selectcountry'] = 	'Select a country';
							   var postURL = 'https://visitor2.constantcontact.com/api/signup';
							</script>
							<script type='text/javascript' src='https://static.ctctcdn.com/h/contacts-embedded-signup-assets/1.0.2/js/signup-form.js'></script>
						
						
						<h3>Follow us on</h3>
						<ul class="social-networks">
							<li><a class="facebook" href="https://www.facebook.com/mouseplanet">Facebook</a></li>
							<li><a class="twitter" href="https://twitter.com/MousePlanet">Twitter</a></li>
							<li><a class="youtube" href="https://www.youtube.com/user/MousePlanetVideo">YouTube</a></li>
							<li><a class="instagram" href="https://instagram.com/mouseplanet/">Instagram</a></li>
						</ul>
					</article>
					<div class="info-wrap">
						<ul class="footer-links">
							<li><a href="/misc/16/About_Us">About</a></li>
							<li><a href="/Contact">Contact Us</a></li>
							<li><a href="/misc/41/Linking_to_MousePlanet">Link to Us</a></li>
							<li><a href="/misc/40/Legal_Information__Privacy_Policy">Legal information and privacy policy </a></li>
						</ul>
						<!-- copyright of the page -->
						<span class="copyright">&copy; 2000-2021 MousePlanet</span>
					</div>
				</div>
			</div>
			<div class="footer-bottom">
				<div class="holder">
					<p>MousePlanet is not associated in any official way with the Walt Disney Company, its subsidiaries. or its affiliates. The official Disney site is available at <a class="site-link" href="https://www.disney.com" target="_blank">www.disney.com</a>. This MousePlanet Web site provides independent news articles, commentary, editorials, reviews. and guides about the Walt Disney Co. All information on this site is subject to change. Please contact destinations in advance to confirm the most up-to-date information.</p>
				</div>
			</div>
			<img src="/images/100px.png">			
		</footer>			</div>
	<!-- required stylesheets and scripts -->
	<script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/jquery/1.11.2/jquery.min.js"></script>
	<script type="text/javascript">window.jQuery || document.write('<script src="/js/jquery-1.11.2.min.js"><\/script>')</script>
	<script type="text/javascript" src="/js/jquery.main.js"></script>

	<script>$(function() {

	    var $allVideos = $("iframe[src*='//player.vimeo.com'], iframe[src*='//www.youtube.com'], object, embed"),
	    $fluidEl = $("p.phototour");

		$allVideos.each(function() {

		  $(this)
		    // jQuery .data does not work on object/embed elements
		    .attr('data-aspectRatio', this.height / this.width)
		    .removeAttr('height')
		    .removeAttr('width');

		});

		$(window).resize(function() {

		  var newWidth = $fluidEl.width();
		  $allVideos.each(function() {

		    var $el = $(this);
		    $el
		        .width(newWidth)
		        .height(newWidth * $el.attr('data-aspectRatio'));

		  });

		}).resize();
	});</script>



</body>
</html>

