

<!DOCTYPE html>
<html>
<head>
	<!-- AID: 13052 - 2021-11-18 - 105  -->

	<!-- set the encoding of your site -->
	<meta charset="utf-8">
	<!-- set the viewport width and initial-scale on mobile devices -->
	<meta name="viewport" content="width=device-width, initial-scale=1.0">
	<meta http-equiv="X-UA-Compatible" content="IE=Edge" />

	<title> Mouseplanet - Finally Experiencing Galaxy's Edge by Todd King </title>

	<!-- include the site stylesheet -->
	<link media="all" rel="stylesheet" href="/css/fancybox.css" />
	<link media="all" rel="stylesheet" href="/css/all.css">

	<meta name="twitter:card" content="summary" />
	<meta name="twitter:site" content="@MousePlanet" />
	<meta name="twitter:title" content="Finally Experiencing Galaxy's Edge" />
	<meta name="twitter:description" content="Part One of a MousePlaneteer's Adventure in Black Spire Outpost" />
	<meta name="twitter:image:src" content="https://www.mouseplanet.info/gallery/d/347199-2/IMG_20211012_112542583.jpg" />
	<meta property="og:url"                content="https://www.mouseplanet.com/13052/Finally_Experiencing_Galaxys_Edge" />
	<meta property="og:type"               content="article" />
	<meta property="og:title"              content="Finally Experiencing Galaxy's Edge" />
	<meta property="og:description"        content="Part One of a MousePlaneteer's Adventure in Black Spire Outpost" />
	<meta property="og:image"              content="https://www.mouseplanet.info/gallery/d/347199-2/IMG_20211012_112542583.jpg" />
	
	<link rel="image_src" href="https://www.mouseplanet.info/gallery/d/347199-2/IMG_20211012_112542583.jpg" / >	
	<link rel="alternate" type="application/rss+xml" title="RSS" href="/rss/articles_feed.xml" />

	
<script type="text/javascript">
String.prototype.trim = function() {
  return this.replace ( /^\s+|\s+$/g, "" );
};
</script>



<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-97843-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-97843-1');
</script>



<!-- Start Google Adsense Mobile Vignettes -->
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-8218384467922636",
    enable_page_level_ads: true
  });
</script>
<!-- End Google Adsense Mobile Vignettes -->



<!-- QST ADS
<script type="text/javascript">
(function() {var s=document.createElement('script'); s.type='text/javascript'; s.async=true; s.src='//qualitysocialtargeting.liqwid.net/?key=D85D-A6F1-B041-B88A';var x=document.getElementsByTagName('script')[0];x.parentNode.insertBefore(s,x);})();
</script>
END OF QST ADS -->

		
	<!-- Start Google DFP -->
	<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
	<script>
	  var googletag = googletag || {};
	  googletag.cmd = googletag.cmd || [];
	</script>
		
	<script type='text/javascript'>
		googletag.cmd.push(function() {
			
		var mapping = googletag.sizeMapping().
			addSize([980, 0], [728, 90]).addSize([640, 0], [300, 250]).build();
		var mapping1 = googletag.sizeMapping().
			addSize([980, 0], [728, 90]).addSize([640, 0], [300, 250]).build();
		var mapping2 = googletag.sizeMapping().
			addSize([980, 0], [728, 90]).addSize([640, 0], [300, 250]).build();
		var mapping3 = googletag.sizeMapping().
			addSize([980, 0], [728, 90]).addSize([640, 0], [300, 250]).build();
		var mapping4 = googletag.sizeMapping().
			addSize([980, 0], [728, 90]).addSize([640, 0], [300, 250]).build();
		var mapping5 = googletag.sizeMapping().
			addSize([980, 0], [728, 90]).addSize([640, 0], [300, 250]).build();
		var mapping6 = googletag.sizeMapping().
			addSize([980, 0], [728, 90]).addSize([640, 0], [300, 250]).build();
		var mapping7 = googletag.sizeMapping().
			addSize([980, 0], [728, 90]).addSize([640, 0], [300, 250]).build();
		var mapping8 = googletag.sizeMapping().
			addSize([980, 0], [728, 90]).addSize([640, 0], [300, 250]).build();
		var mapping9 = googletag.sizeMapping().
			addSize([980, 0], [728, 90]).addSize([640, 0], [300, 250]).build();
		var mapping10 = googletag.sizeMapping().
			addSize([980, 0], [728, 90]).addSize([640, 0], [300, 250]).build();
		var mapping11 = googletag.sizeMapping().
			addSize([980, 0], [728, 90]).addSize([640, 0], [300, 250]).build();
		var mapping12 = googletag.sizeMapping().
			addSize([980, 0], [728, 90]).addSize([640, 0], [300, 250]).build();
		var mapping13 = googletag.sizeMapping().
			addSize([980, 0], [728, 90]).addSize([640, 0], [300, 250]).build();
		
			    googletag.defineSlot('/1046630/col_lb', [[300, 250], [728, 90]], 'div-gpt-ad-1324422172992-2').defineSizeMapping(mapping1).addService(googletag.pubads());	    googletag.defineSlot('/1046630/col_cube', [[300, 600], [300, 250]], 'div-gpt-ad-1324422172992-0').addService(googletag.pubads());			
		googletag.defineSlot('/1046630/ros_footer', [728, 90], 'div-gpt-ad-1324422172992-25').addService(googletag.pubads());
	    googletag.pubads().enableSingleRequest();
	    googletag.enableServices();
	    googletag.pubads().collapseEmptyDivs();
	
		});
		</script>
		<!-- End Google DFP -->			
		

	<script type="text/javascript">
		$(document).ready(function() {
			var photoList = $('.phototour img');
			if (photoList.length) {
				$('meta[name="twitter:image:src"]').attr('content', photoList[0].src);
			}
		});
	</script>

</head>
<body>
	<!-- main container of all the page elements -->
	<div id="wrapper">
		

<div class="top-bar">
			<div class="top-holder">
				<ul class="social-networks">
					<li><span class="text-follow">Follow us on</span></li>
					<li><a class="facebook" href="https://www.facebook.com/mouseplanet" target="_blank">Facebook</a></li>
					<li><a class="twitter" href="https://twitter.com/MousePlanet" target="_blank">Twitter</a></li>
					<li><a class="youtube" href="https://www.youtube.com/user/MousePlanetVideo" target="_blank">Youtube</a></li>
					<li><a class="instagram" href="https://instagram.com/mouseplanet/">Instagram</a></li>
				</ul>
			</div>
		</div>
		<!-- header of the page -->
		<header id="header">
			<div class="holder">
				<!-- logo of the page -->
				<div class="logo">
					<a href="/"><img src="/mplogo.gif" alt="MousePlanet"></a>
				</div>
				<!-- main navigation of the page -->
				<nav id="nav">
					<!-- <div class="open-close"> -->
					<a href="#" class="nav-opener"><span></span></a>
					<div class="drop">
						<!-- search-form of the page -->
						<form action="/search.php" class="search-form" method="post">
							<fieldset>
								<div class="row">
									<input type="search" id="t" name="t" placeholder="Search">
									<input type="submit">
								</div>
							</fieldset>
						</form>
						<ul>
							<li>
								<a href="/articles.php">Articles</a>
							</li>
							<li><a href="/guide/1/Disneyland-Resort">Disneyland Guide</a>
								<ul class="dropmenu">
									<li><a href="/guide/1/Disneyland-Resort">Quick Facts</a></li>
									<li><a href="/tag/2/Disneyland_Resort_Update/">Resort Updates</a></li>
									<li><a href="/guide/448/Disneyland-Resort/Disneyland-Park">Disneyland</a></li>
									<li><a href="/guide/274/Disneyland-Resort/Disney-California-Adventure">Disney California Adventure</a></li>
									<li><a href="/guide/464/Disneyland-Resort/Downtown-Disney">Downtown Disney</a></li>
									<li><a href="http://mousepad.mouseplanet.com/forumdisplay.php?53-Trip-Reports-from-California">Trip Reports</a></li>
								</ul>
							</li>
							<li><a href="/guide/2/Walt-Disney-World">Walt Disney World Guide</a>
								<ul class="dropmenu">
									<li><a href="/guide/2/Walt-Disney-World">Quick Facts</a></li>
									<li><a href="/tag/101/Walt_Disney_World_Resort_Update/">Resort Updates</a></li>
									<li><a href="/guide/550/Walt-Disney-World/Magic-Kingdom">Magic Kingdom</a></li>
									<li><a href="/guide/303/Walt-Disney-World/Epcot">Epcot</a></li>
									<li><a href="/guide/436/Walt-Disney-World/Disneys-Hollywood-Studios">Disney's Hollywood Studios</a></li>
									<li><a href="/guide/15/Walt-Disney-World/Disneys-Animal-Kingdom">Disney's Animal Kingdom</a></li>
									<li><a href="/guide/395/Walt-Disney-World/Downtown-Disney">Downtown Disney / Disney Springs</a></li>
									<li><a href="http://mousepad.mouseplanet.com/forumdisplay.php?54-Trip-Reports-from-Floridaa">Trip Reports</a></li>
								</ul>
							</li>
							<li><a href="http://mousepad.mouseplanet.com">Forum</a></li>
						</ul>
					</div>
					<!-- </div> -->
				</nav>
			</div>
		</header>		<!-- contain main informative part of the site -->
		<main id="main" role="main">
			<div class="holder padding">
				<div class="ad-holder">
					<!-- col_lb -->
<div id='div-gpt-ad-1324422172992-2'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1324422172992-2'); });
</script>
</div>				</div>

				<div class="heading">
										<h1>Finally Experiencing Galaxy's Edge</h1>
					
											by <a href="/author/75/Todd_King/" class="name">Todd King</a>, contributing writer						<a href="/contact/w/75/Todd-King" title='Send Todd King an email'><img src="/images/mail.png" height="20"></a>
										<time datetime="2021-11-18">November 18, 2021</time>
				</div>

				<div class="content-holder">
					<div class="ad-block">
						<h6>Advertisement</h6>
						<div class="ad-holder">
							<!-- col_cube -->
<div id='div-gpt-ad-1324422172992-0'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1324422172992-0'); });
</script>
</div>						</div>
					</div>
					<div class="text-holder">
						<p>I finally made it! The "Star Wars guy" at MousePlanet finally visited Galaxy's Edge! As Darth Vader would say, "the circle is now complete."</p>

<p>I hadn't been to Walt Disney World in about five years, which was before Galaxy's Edge existed. The only new Star Wars thing at the time was <a href="https://www.mouseplanet.com/11388/A_Star_Wars_Fan_visits_the_Launch_Bay">Launch Bay, which I wrote about back in 2016</a>. Before and after that visit, I had been predicting what "Star Wars Land" would be like. And since Galaxy's Edge opened, I have only imagined what it would feel like. The global pandemic slowed down my plans but as vaccinations became more widespread, I started scheming my journey this past March for an October landing. The short version is that I made it there with my family safely, we had a pretty wonderful time, I met a fellow MousePlaneteer in person, and made it back home alive, well, and happy. And now it all feels like a dream.</p>

<p>Naturally I'm being asked, "Well, what did you think?" You ask a Star Wars fan, or a Disney parks fan, or someone who's both, and it won't be a very short answer. In true Star Wars form, I'll have to answer that question in a trilogy! A trilogy of articles. Here is Part 1:</p>

<h3>Rise of the Line</h3>

<p>My adventure began early in the morning on a Tuesday. Disney's Hollywood Studios was set to open at 9:00 AM, but as guests on Disney property, we could enter in at 8:30 a.m., which we did. Almost. There were some transportation issues that I may get into later. We did get there <em>before</em> 9:00.</p>

<p>Cast members stood waving to us on the side of the streets, not just to wish us good morning, but to usher us to what they knew was the reason we came&mdash;to get in line for Rise of the Resistance. "This way to the line for Rise of the Resistance&hellip;&nbsp;a one-hour wait!&nbsp;Mickey and Minnie's Runaway Railway is only a 30-minute wait!"</p>

<p>Then as we walked on past the Chinese Theater, the greetings continued, "This way to Rise! A one-and-a-half-hour wait!" I couldn't take the shortcuts I'd mapped in my head. No, cast members were strategically placed in front of side streets to control traffic. There was only one direction to go. We got near the entrance to Batuu and there was more two-finger pointing, "This way for the line to Rise! A two-hour wait!"</p>

<p>We swung a right on Pixar Place and into a usually closed backstage area where the line took a loop <em>out</em>&mdash;and then back <em>in</em>&mdash;Pixar Place. Behind the Chinese Theater we finally reached the saga's beginning: a two-and-a-half-hour wait.</p>

<p>Note: Our trip this past October was in the unsweet spot where there was no virtual queue and no Genie+. This was pure stand-by. But no old-school line ever snaked its way so far away from an attraction's entrance that'd I had ever known.</p>

<p>We had the whole day in front of us so as they say on the Haunted Mansion, there was no turning back now. The wait time for Rise of the Resistance never got below two and a half hours the rest of the day, so&nbsp;it didn't matter. Here we were. Let the "immersion" begin.</p>

<p>When the line finally advanced into Black Spire Outpost itself, I could start to take it all in.</p>

<h3>Devil in the Details</h3>

<p class="phototour"><a href="https://www.mouseplanet.info/gallery/d/347139-2/IMG_20211012_095750670.jpg" target="_blank"><img alt="Me and an A-Wing" src="https://www.mouseplanet.info/gallery/d/347139-2/IMG_20211012_095750670.jpg" style="width: 560px; height: 420px; max-width: 100%;"></a><br>
A-Wing next to me for scale. Photo by Todd King.</p>

<p>One of the first things I saw was a life-size A-Wing fighter nestled into a cove that would normally be the edge of the land, but now was a guide mark for our long line. The A-Wing is a great addition to the park, especially since it comes out of the original trilogy&mdash;first being seen in <em>Return of the Jedi</em> and inspiring other ship designs across the movies like the Jedi Starfighter in the prequels. You ever feel like Art from <em>Monsters University</em> and think, "I wanna touch 'em"? Well, I wanted to touch everything! If only it weren't for those themed dividers!</p>

<p class="phototour"><a href="https://www.mouseplanet.info/gallery/d/347133-2/IMG_20211012_095815789.jpg" target="_blank"><img alt="A-Wing" src="https://www.mouseplanet.info/gallery/d/347133-2/IMG_20211012_095815789.jpg" style="width: 560px; height: 420px; max-width: 100%;"></a><br>
A-Wing on display. Photo by Todd King.</p>

<p>As the line moved like a sandcrawler, I observed as many details as I could&mdash;like these prints on the path:</p>

<p class="phototour"><a href="https://www.mouseplanet.info/gallery/d/347145-2/IMG_20211012_100122881.jpg" target="_blank"><img alt="Footprints in the path" src="https://www.mouseplanet.info/gallery/d/347145-2/IMG_20211012_100122881.jpg" style="width: 560px; height: 420px; max-width: 100%;"></a><br>
You can find small details everywhere like these footprints that look suspiciously Gungan. Photo by Todd King.</p>

<p>Even in autumn it's still oppressively hot in <s>Florida</s> Black Spire and luckily, there was a drink cart in the line!</p>

<p class="phototour"><a href="https://www.mouseplanet.info/gallery/d/347151-2/IMG_20211012_100335314.jpg" target="_blank"><img alt="Footprints in the path" src="https://www.mouseplanet.info/gallery/d/347151-2/IMG_20211012_100335314.jpg" style="width: 560px; height: 420px; max-width: 100%;"></a><br>
The famous Coke bottles, shaped like thermal detonators, provided refreshness in the line for Rise. Photo by Todd King.</p>

<p>Many denizens of Batuu helped us all stay in this imaginary line through the middle of an avenue and then actually turned back around and out of Black Spire and sidled adjacent to Muppet Vision 3D's courtyard for a bit. Remember that episode of <em>The Muppet Show</em> with Luke Skywalker <em>and</em> Mark Hamill? Was this a callback reference? No, just some imaginative crowd control that broke any immersion I had been feeling. As the Viceroy once said in <em>Attack of the Clones</em>, "This is not how it's supposed to be."</p>

<p>Eventually we arrived at the entrance! Just over half our journey in the line was behind us&hellip;</p>

<p class="phototour"><a href="https://www.mouseplanet.info/gallery/d/347157-2/IMG_20211012_101147522.jpg" target="_blank"><img alt="Entrance to Rise" src="https://www.mouseplanet.info/gallery/d/347157-2/IMG_20211012_101147522.jpg" style="width: 560px; height: 420px; max-width: 100%;"></a><br>
Without a virtual queue, and no Genie+ yet, Rise of the Resistance was stand-by only. Macklunky! Photo by Todd King.</p>

<p class="phototour"><a href="https://www.mouseplanet.info/gallery/d/347169-2/IMG_20211012_105047275.jpg" target="_blank"><img alt="Not all spires a black, here's a small waterfall at the entrance" src="https://www.mouseplanet.info/gallery/d/347169-2/IMG_20211012_105047275.jpg" style="width: 560px; height: 420px; max-width: 100%;"></a><br>
More details include this small waterfall making Black Spire Outpost feel organic. Photo by Todd King.</p>

<h3>Into the Base</h3>

<p>Thank the maker that air conditioning exists in this galaxy! We finally got inside&hellip;&nbsp;a cave? When the Rebels, or the Resistance, intend to hide their base, they mean it! We began winding through caverns and corridors no Stormtrooper would ever dare to go.</p>

<p class="phototour"><a href="https://www.mouseplanet.info/gallery/d/347175-2/IMG_20211012_110344689.jpg" target="_blank"><img alt="Rebel radar screens" src="https://www.mouseplanet.info/gallery/d/347175-2/IMG_20211012_110344689.jpg" style="width: 560px; height: 420px; max-width: 100%;"></a><br>
Set pieces like this radar screen hits the immersion button hard and makes you feel like you're really in the Resistance base. Photo by Todd King.</p>

<p>There were several themed details throughout the line. My phone's lousy camera couldn't make great details within the indoor darkness but there are cabinets full of blasters and pilot suits that look genuine to the movies. But again, no touchies. The scattered pieces and shelves did set the mood well and let you know you're in the realm of the good guys who always have to hide themselves. I love the radar screens and space crates laying around&mdash;it reminds me of the details in Pirates of the Caribbean with its cannonballs and barrels strewn about. Gimme those themed queues! Ahhh&hellip;</p>

<h3>Guess what? You're on the ride already!</h3>

<p>Suddenly, there was Rey!</p>

<p class="phototour"><a href="https://www.mouseplanet.info/gallery/d/347181-2/IMG_20211012_111522208.jpg" target="_blank"><img alt="Rey in a hologram next to BB-8" src="https://www.mouseplanet.info/gallery/d/347181-2/IMG_20211012_111522208.jpg" style="width: 560px; height: 420px; max-width: 100%;"></a><br>
Seeing a "hologram" of Rey and a real BB-8 truly set the stage for the experience ahead. Photo by Todd King.</p>

<p>This was great! A mix of all Disney magic was to be found in this room. A "hologram" Rey and an animatronic BB-8 prepare you for the transport into adventure. It's a fantastic effect that fits the Star Wars world and it works very effectively. Daisy Ridley executed this part perfectly and it just went by too fast&mdash;I wanted to raise my hand and ask her a few questions. No time! We've got a shuttle to board!</p>

<p>The scene with Rey is obviously the first part of the attraction but it took me a moment to realize that I had already been immersed in the attraction for a little while and now things were gearing up. This wasn't just ride-prep like the videos before Soarin' and Star Tours; this was the attraction itself beginning its storytelling. It's very Star Wars-like because the best action/battle scenes in the films were made better by their tense set-ups! So, here I was in a new Star Wars sequence!</p>

<p>Next, we were back outside. Huh? We were in a small couryard next to some big doors. This part reminds you that you're still on Batuu, but in a secret area. No more lines here! We were a group now.</p>

<p>Then you look a little more and realize the doors are part of a shuttle. It opens at ground level and all of us, walking or in mobile chairs, could easily board. Inside the ship, I was amazed to be greeted by an animatronic Mon Calimari captain with hi-res screens at the cockpit and the tail. No seats here yet as we all stood grasping handles like on a Disney Monorail.</p>

<p>The ship takes off and we see out the cockpit that we fly over the black spires and into space. You can look out the front to see our trajectory, or out the rear to see us leaving the planet. This is very Disney-like and reminded me of Circlevision 360 attractions (Like China and Canada in Epcot) where you can turn your head to see the same scene from a different point of view. Since we were standing it wasn't too jerky but had just enough movement and vibration to give the right sensations.</p>

<h3>It's a trap!</h3>

<p>Rebels never make it too far in space without facing a battle or getting caught and so things went wrong about as quick as they do in the first minutes of <em>A New Hope</em>. We moved into a laser fight with the First Order only to get caught in their Star Destroyer's tractor beam. Shades of the old Star Tours eh? But this time, there was no way to "ease off your main thruster" to escape.</p>

<p>The shuttle docked inside and&hellip;&nbsp;then&hellip;&nbsp;the doors&hellip;&nbsp;opened&hellip;</p>

<p class="phototour"><a href="https://www.mouseplanet.info/gallery/d/347187-2/IMG_20211012_112011827.jpg" target="_blank"><img alt="Captured by First Order Stormtroopers" src="https://www.mouseplanet.info/gallery/d/347187-2/IMG_20211012_112011827.jpg" style="width: 560px; height: 420px; max-width: 100%;"></a><br>
You may have seen photos of all the Stormtroopers, but I was legit taken aback when the shuttle doors opened into the hangar bay. Photo by Todd King.</p>

<p>Again, my camera takes blurry pics indoors but I had to share the above photo. I happened to be by the doors and when they opened. Well, I'd seen pictures of this room all over the Internet but let me tell you&mdash;when those blast doors opened and I first saw this room with my own eyes, I was honestly a bit scared. This was intimidating. For a moment, I couldn't move. I was both amazed and shocked. People in the shuttle had to tell me to step forward and the First Order officers had to wave me in. There was a flash of a moment where&hellip;&nbsp;I believed.</p>

<p>Pictures don't do the size of this hangar justice. It is truly awesome in its magnitude. The line of Stormtroopers is snazzy, to say the least. It would be interesting if they were interactive in some way&mdash;like if you shouted, "Hey look! The Emperor!" and they all slap into attention. Anyway, I did get a moment to breathe it in a little, but we were ordered to the side hallway with undue haste.</p>

<p class="phototour"><a href="https://www.mouseplanet.info/gallery/d/347193-2/IMG_20211012_112040136.jpg" target="_blank"><img alt="Life-size First Order TIE Fighter" src="https://www.mouseplanet.info/gallery/d/347193-2/IMG_20211012_112040136.jpg" style="width: 560px; height: 420px; max-width: 100%;"></a><br>
Life-size TIE Fighter? I almost got separated from my group gazing at this thing. Photo by Todd King.</p>

<p class="phototour"><a href="https://www.mouseplanet.info/gallery/d/347199-2/IMG_20211012_112542583.jpg" target="_blank"><img alt="Stormtrooper Animatronics" src="https://www.mouseplanet.info/gallery/d/347199-2/IMG_20211012_112542583.jpg" style="width: 560px; height: 420px; max-width: 100%;"></a><br>
Before the "interrogation," there are more animatronics silently watching you. Photo by Todd King.</p>

<p>I have no more photos of Rise of the Resistance because you're <em>riding </em>from here on out. So up to this point I'd entered the hidden base, got a briefing by Rey, boarded a shuttle, got captured by the First Order, disembarked onto a Star Destroyer's hangar bay, lined up to be interrogated, and the sit-down "ride" portion hadn't begun yet!</p>

<p>To my mind, this harkens back to embryonic designs for attractions like Pirates once being a walk-through wax museum and the Haunted Mansion being a walk-through experience as well with scene after scene of stories and illusions. Those designs were mostly abandoned but it seems that imagineers for Galaxy's Edge cleared the drawing board, let all ideas new and old live, and wiped out the rules. Why can't we have walk-through portions? Here, they've done it and it is a pleasurable experience. Having feet on the ground in these amazing scenes makes it visceral and raises my expectations for future attractions.</p>

<p>At this point, you're on the trackless dark ride through many scenes, lots of lasers, an animatronic Finn(!), monstorously scaled Imperial-like walkers, life-like stereoscopic 3D appearances by Kylo Ren and General Hux (played by Domnhall Gleeson, who, it should be noted, also makes a similar appearance in Gringott's at Universal&mdash;that guy is the theme park Kevin Bacon!), and a simulator lightspeed portion that is a perfect finale.</p>

<h3>Back on the Ground</h3>

<p>So, yes, it is truly marvelous, a sight to behold, and pushes the theme park ride experience into some grand territory. I would ride it again and again if I could, if the line wasn't a hot mess.</p>

<p>Rise of the Resistance is great, but it isn't perfect. I don't know about Genie+ but stand-by was an abject failure. They should have had virtual queue that week. Even so, it wasn't a 4-, 5-, or 6-hour wait like Pandora had early on.</p>

<p>I wanted to mill about more in the hangar, but I know they want to keep us moving and give us a reason to come back. Kylo Ren's dramatic lightsaber ceiling-cutting didn't work while we were on it so it just looked like a stick poking out of an already sliced roof.</p>

<p>Later in the day Rise of the Resistance broke down and extended the already-galactic wait time. People were laying down anywhere they could to wait it out and stay in line.</p>

<p>The sheer enormity of the attraction and its complexities lead me to believe this could never be re-themed. Why re-theme it? Well, it's a great attraction but I couldn't deny that deep down I thought how much more wonderous this would be if it took place in the time of the Original Trilogy. That thought persisted a bit through the park but it didn't detract from the great atmosphere and the cool discoveries.</p>

<h3>To be Continued</h3>

<p>Parts 2 and 3 will cover the rest of my experience in Galaxy's Edge including the shops, the food, the characters, building a lightsaber, and of course, riding Smuggler's Run and flying the Millennium Falcon! Plus, I'll formulate my overall musings of Star Wars land and what it means to me.</p>
<p>&nbsp</p>
					<p>
						<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
						<ins class="adsbygoogle"
						     style="display:block"
						     data-ad-format="autorelaxed"
						     data-ad-client="ca-pub-8218384467922636"
						     data-ad-slot="7483507399"></ins>
						<script>
						     (adsbygoogle = window.adsbygoogle || []).push({});
						</script>

					</p>

					</div>
				<div class="social-block">
					<div class="info-share">
						<h4>Share this article</h4>
							<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-514bcc3157fb0a34" async="async"></script>
							<div class="addthis_sharing_toolbox"></div>
					</div>
					<div class="info-tag">
						<h4>Tags</h4>
						<ul class="list-tags">
							<li><a href="/tag/105/Disneys_Hollywood_Studios/">Disneys Hollywood Studios</a></li><li><a href="/tag/1339/Galaxys_Edge/">Galaxys Edge</a></li><li><a href="/tag/502/Star_Wars/">Star Wars</a></li><li><a href="/tag/1446/Star_Wars_Galaxys_Edge/">Star Wars Galaxys Edge</a></li>						</ul>
					</div>
				</div>

				<article class="article-info">
					<h4>Similar Articles</h4>
					<ul class="list-articles">

							<li>	<a href="/13002/Previewing_Immersion_on_the_Star_Wars_Galactic_Starcruiser" class="img-holder">	<img src=" https://www.mouseplanet.info/gallery/d/344681-1/star-wars-galactic-starcruiser-poster-splash.jpg" alt="Previewing Immersion on the Star Wars Galactic Starcruiser" width="261" height="193"></a>	<a href="/13002/Previewing_Immersion_on_the_Star_Wars_Galactic_Starcruiser" class="title">Previewing Immersion on the Star Wars Galactic Starcruiser</a>	<br /><span class="author">by <a href="/13002/Previewing_Immersion_on_the_Star_Wars_Galactic_Starcruiser" class="name">Todd King</a> <time datetime="2021-08-19">August 19, 2021</time></span>  </li><li>	<a href="/12174/My_Disney_Top_5__Things_to_See_in_Toy_Story_Land_at_Disneys_Hollywood_Studios" class="img-holder">	<img src=" https://www.mouseplanet.info/gallery/d/299706-2/Slinky+Dog+Plans.jpg" alt="My Disney Top 5 - Things to See in Toy Story Land at Disney's Hollywood Studios" width="261" height="193"></a>	<a href="/12174/My_Disney_Top_5__Things_to_See_in_Toy_Story_Land_at_Disneys_Hollywood_Studios" class="title">My Disney Top 5 - Things to See in Toy Story Land at Disney's Hollywood Studios</a>	<br /><span class="author">by <a href="/12174/My_Disney_Top_5__Things_to_See_in_Toy_Story_Land_at_Disneys_Hollywood_Studios" class="name">Chris Barry</a> <time datetime="2018-08-17">August 17, 2018</time></span>  </li><li>	<a href="/12157/My_Disney_Top_5__Things_to_See_on_Sunset_Boulevard_in_Disneys_Hollywood_Studios" class="img-holder">	<img src=" https://www.mouseplanet.info/gallery/d/299117-2/Carthay+Sunset+Boulevard.jpg" alt="My Disney Top 5 - Things to See on Sunset Boulevard in Disney's Hollywood Studios" width="261" height="193"></a>	<a href="/12157/My_Disney_Top_5__Things_to_See_on_Sunset_Boulevard_in_Disneys_Hollywood_Studios" class="title">My Disney Top 5 - Things to See on Sunset Boulevard in Disney's Hollywood Studios</a>	<br /><span class="author">by <a href="/12157/My_Disney_Top_5__Things_to_See_on_Sunset_Boulevard_in_Disneys_Hollywood_Studios" class="name">Chris Barry</a> <time datetime="2018-08-03">August 3, 2018</time></span>  </li>


					</ul>					
				</article>
			</div>

			<div class="comment-block">
				<div class="holder">
					<h2>Comments</h2>
					<ol class="list-comments">

						<li><strong class="comment-info"><a href="https://mousepad.mouseplanet.com/showthread.php?t=310955" target="_blank">Discuss this article on MousePad.</a></strong>						
					</ol>
				</div>
			</div>
			<div class="ad-holder has-margin">
					<!-- ros_footer -->
<div id='div-gpt-ad-1324422172992-25' >
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1324422172992-25'); });
</script>
</div>			</div>
		</main>
		<footer id="footer">
			<div class="footer-area">
				<div class="holder">
					<article class="col-left">
						<h2>About MousePlanet</h2>
						<p>MousePlanet is your independent consumer guide to Disney travel and vacations, covering Disneyland, Walt Disney World and the Disney Cruise Line. Look to MousePlanet for daily news, weekly theme park updates, and detailed travel and resort guides for your favorite Disney destinations. As with any endeavor of this size and complexity, we couldn't hope to succeed without the assistance of our readers. We encourage you to submit news, updates and feedback from your Disney travels.</p>
					</article>
					<article class="col-right">
						<h2>Join Our Newsletter</h2>
						<p>Subscribe to our weekly newsletter for all the latest updates.</p>


							<div class="ctct-embed-signup" style="font: 16px Helvetica Neue, Arial, sans-serif; font: 1rem Helvetica Neue, Arial, sans-serif; line-height: 1.5; -webkit-font-smoothing: antialiased;">
							   <div style="color:#5b5b5b; background-color:#146cba; border-radius:5px;">
							       <span id="success_message" style="display:none;">
							           <div style="text-align:center;"><h3>Thanks for signing up!</h3></div>
							       </span>
							       <form data-id="embedded_signup:form" class="ctct-custom-form Form" name="embedded_signup" method="POST" action="https://visitor2.constantcontact.com/api/signup">
							           <p></p>
							           <div class="email-form">
							           <!-- The following code must be included to ensure your sign-up form works properly. -->
							           <input data-id="ca:input" name="ca" value="37989a29-c267-4e1d-b2a8-6939f994d994" type="hidden">
							           <input data-id="list:input" name="list" value="1" type="hidden">
							           <input data-id="source:input" name="source" value="EFD" type="hidden">
							           <input data-id="required:input" name="required" value="list,email" type="hidden">
							           <input data-id="url:input" name="url" value="" type="hidden">
							           <p data-id="Email Address:p" > <input data-id="Email Address:input" name="email" value="" placeholder="Email Address" maxlength="80" type="text">
							           <input type="submit"  data-enabled="enabled" value="Go">
							           </div>
							       </form>
							   </div>
							</div>
							<script type='text/javascript'>
							   var localizedErrMap = {};
							   localizedErrMap['required'] = 		'This field is required.';
							   localizedErrMap['ca'] = 			'An unexpected error occurred while attempting to send email.';
							   localizedErrMap['email'] = 			'Please enter your email address in name@email.com format.';
							   localizedErrMap['birthday'] = 		'Please enter birthday in MM/DD format.';
							   localizedErrMap['anniversary'] = 	'Please enter anniversary in MM/DD/YYYY format.';
							   localizedErrMap['custom_date'] = 	'Please enter this date in MM/DD/YYYY format.';
							   localizedErrMap['list'] = 			'Please select at least one email list.';
							   localizedErrMap['generic'] = 		'This field is invalid.';
							   localizedErrMap['shared'] = 		'Sorry, we could not complete your sign-up. Please contact us to resolve this.';
							   localizedErrMap['state_mismatch'] = 'Mismatched State/Province and Country.';
								localizedErrMap['state_province'] = 'Select a state/province';
							   localizedErrMap['selectcountry'] = 	'Select a country';
							   var postURL = 'https://visitor2.constantcontact.com/api/signup';
							</script>
							<script type='text/javascript' src='https://static.ctctcdn.com/h/contacts-embedded-signup-assets/1.0.2/js/signup-form.js'></script>
						
						
						<h3>Follow us on</h3>
						<ul class="social-networks">
							<li><a class="facebook" href="https://www.facebook.com/mouseplanet">Facebook</a></li>
							<li><a class="twitter" href="https://twitter.com/MousePlanet">Twitter</a></li>
							<li><a class="youtube" href="https://www.youtube.com/user/MousePlanetVideo">YouTube</a></li>
							<li><a class="instagram" href="https://instagram.com/mouseplanet/">Instagram</a></li>
						</ul>
					</article>
					<div class="info-wrap">
						<ul class="footer-links">
							<li><a href="/misc/16/About_Us">About</a></li>
							<li><a href="/Contact">Contact Us</a></li>
							<li><a href="/misc/41/Linking_to_MousePlanet">Link to Us</a></li>
							<li><a href="/misc/40/Legal_Information__Privacy_Policy">Legal information and privacy policy </a></li>
						</ul>
						<!-- copyright of the page -->
						<span class="copyright">&copy; 2000-2021 MousePlanet</span>
					</div>
				</div>
			</div>
			<div class="footer-bottom">
				<div class="holder">
					<p>MousePlanet is not associated in any official way with the Walt Disney Company, its subsidiaries. or its affiliates. The official Disney site is available at <a class="site-link" href="https://www.disney.com" target="_blank">www.disney.com</a>. This MousePlanet Web site provides independent news articles, commentary, editorials, reviews. and guides about the Walt Disney Co. All information on this site is subject to change. Please contact destinations in advance to confirm the most up-to-date information.</p>
				</div>
			</div>
			<img src="/images/100px.png">			
		</footer>			</div>
	<!-- required stylesheets and scripts -->
	<script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/jquery/1.11.2/jquery.min.js"></script>
	<script type="text/javascript">window.jQuery || document.write('<script src="/js/jquery-1.11.2.min.js"><\/script>')</script>
	<script type="text/javascript" src="/js/jquery.main.js"></script>

	<script>$(function() {

	    var $allVideos = $("iframe[src*='//player.vimeo.com'], iframe[src*='//www.youtube.com'], object, embed"),
	    $fluidEl = $("p.phototour");

		$allVideos.each(function() {

		  $(this)
		    // jQuery .data does not work on object/embed elements
		    .attr('data-aspectRatio', this.height / this.width)
		    .removeAttr('height')
		    .removeAttr('width');

		});

		$(window).resize(function() {

		  var newWidth = $fluidEl.width();
		  $allVideos.each(function() {

		    var $el = $(this);
		    $el
		        .width(newWidth)
		        .height(newWidth * $el.attr('data-aspectRatio'));

		  });

		}).resize();
	});</script>



</body>
</html>

